Default Trying to use Casual with rooted 4.1.2 on SCH-1605(note 2)

Im a noob and have been trying to use casual to unlock my bootloader. I have a rooted version of 4.1.2 flashed through odin on my SH-1605. Ive tried it twice now and it hasn't worked. This is what i am getting from casual. I had to shorten it quite a bit but i think i got the main error.

This is a tool which will root, unlock, and install a custom recovery on a Verizon Galaxy Note 2.

Initialising connection...
Detecting device...
Claiming interface...
Setting up interface...

Checking if protocol is initialised...
Protocol is not initialised.

Initialising protocol...
Protocol initialisation successful.

Beginning session...

This device may take up to 2 minutes to respond.
Please be patient!

Session begun.

Uploading PIT
PIT upload successful

Uploading BOOTLOADER
100%
ERROR: Failed to confirm end of file transfer sequence!
ERROR: BOOTLOADER upload failed!

Ending session...
ERROR: Failed to send end session packet!
Releasing device interface...


[Heimdall Error Report] Detected:
Heimdall uncontinuable error; Script halted
[/Heimdall Error Report]


done
Script Complete

Any help would be appreciated!