5,601,223 Members 51,351 Now Online
XDA Developers Android and Mobile Development Forum

Galxy S4 - Not registering on Network

Tip us?
 
imsosa
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Dec 2013
Unhappy Galxy S4 - Not registering on Network

Hi, i've been using my S4 since May of this year.. It was originally bought in Canada (rogers) and I have been using it on Tmobile in Las Vegas since May... There were no problems until the other day. Out of now where it stopped working. It does not read sim. I went to the Tmobile store and got a replacement sim but still no luck. The sim works in another phone just fine...

Does anyone why it won't connect to the network? There was an update on my phone about a week ago and i did update it to the latest software.
Very frustrating. hope someone can help.

thanks
 
imsosa
Old
#2  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Dec 2013
Quote:
Originally Posted by Sana2 View Post
Did you root it ? Or you should uinstall some apps that have just installed
Im not sure how uninstalling apps will help. Lol
And no. Not rooted it.
 
smilingcruel
Old
#3  
smilingcruel's Avatar
Senior Member
Thanks Meter 32
Posts: 161
Join Date: Jun 2011
Location: ******
Are you seeing the correct IMEI number in your phone or is it just showing bunch of zeros...?

Sent from my SGH-M919 using xda app-developers app
 
Android_Monsters
Old
#4  
Android_Monsters's Avatar
Senior Member
Thanks Meter 748
Posts: 2,741
Join Date: Feb 2012
Location: Los Angeles
Could Odin the stock image.

Sent from my SGH-M919 using XDA Premium 4 mobile app
 
aamir123
Old
#5  
Senior Member
Thanks Meter 116
Posts: 846
Join Date: Dec 2010
Was it bought from the store or second hand? May be imei block

Sent from my SGH-T999 using xda app-developers app
 
tronac
Old
#6  
Member
Thanks Meter 6
Posts: 30
Join Date: Nov 2013
Quote:
Originally Posted by imsosa View Post
Hi, i've been using my S4 since May of this year.. It was originally bought in Canada (rogers) and I have been using it on Tmobile in Las Vegas since May... There were no problems until the other day. Out of now where it stopped working. It does not read sim. I went to the Tmobile store and got a replacement sim but still no luck. The sim works in another phone just fine...

Does anyone why it won't connect to the network? There was an update on my phone about a week ago and i did update it to the latest software.
Very frustrating. hope someone can help.

thanks
The update to 4.3 is the cause of your problems. Your phone is the I337M from Rogers which had the AWS bands enabled. Many people have reported losing their AWS with the update. If you are in an area where T-mobile has 1900Mhz connectivity then you should not be having a problem even with the update.
 
Misterjunky
Old
#7  
Misterjunky's Avatar
Senior Member
Thanks Meter 1876
Posts: 3,942
Join Date: Jan 2011
Location: Bakersfield, California

 
DONATE TO ME
Thumbs up re: modem.bin

Quote:
Originally Posted by imsosa View Post
Hi, i've been using my S4 since May of this year.. It was originally bought in Canada (rogers) and I have been using it on Tmobile in Las Vegas since May... There were no problems until the other day. Out of now where it stopped working. It does not read sim. I went to the Tmobile store and got a replacement sim but still no luck. The sim works in another phone just fine...

Does anyone why it won't connect to the network? There was an update on my phone about a week ago and i did update it to the latest software.
Very frustrating. hope someone can help.

thanks
NOTICE: If you are running/using any AOSP/AOKP/CM/GE/KitKat or any PORTED roms
then the following does NOT apply to you.!!!


Have you tried this:

You can Odin flash the MK2 modem.bin while on any Jellybean Touchwiz 4.2.2 based rom
or ODIN flash it after flashing the Infamous v9, Wicked v9.1, or any M919 MK2 JB based
Touchwiz 4.3 roms. Either way it makes no difference.

What does make a difference is to follow this step by step exactly.

#1: Manually power down the phone by using the power button only.
#2: Start ODIN and put the MODEM.BIN file into ODIN'S PHONE slot.
#3: Put the phone into download mode using the volume down and power button.
#4: Plug the USB cable into the phone and into the computer.
#5: Make sure that ODIN'S [COM:xx] lights up.
#6: Un-Check the Auto-Reboot in ODIN and click START.
#7: After its done flashing unplug the usb cable.
#8: Manually power off the phone by using the power button only.
#9: Wait 20 or so seconds before you power on the phone.

After doing this the MK2 baseband should show up in About Device.

Once it displays MK2 you can flash any MK2 JB TW 4.3 custom cwm/twrp zip file roms unless you have
already flashed it before flashing the modem.bin in which case you are done and ready to use the phone.

NOTE: this modem.bin is the official Tmobile M919 MDL radio which is meant to work anywhere in the USA.
Since none of these 4.2.2 & 4.3 custom zip file roms contain radios you are left with the Canadian modem
in your phone. That's why this step by step should work fine for you.

The only thing which may not work perfectly would be LTE because that's a separate radio (non-hlos.bin)
which must be copied from a MDL based Tmobile M919 Jellybean TW official 4.3 or 4.2.2 Odin flash TAR
firmware.

Here is the direct download link for the Tmobile 4.3 M919 MK2 modem.bin:
http://www.mediafire.com/download/1g...l89x/modem.bin

Good luck!
Have a great day, enjoy!

Don't forget it takes less time to click the "THANKS" button than to type "thank you".
(unless you type very fast).




Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


XDA PORTAL POSTS

Decompile, Edit, and Recompile in One Tool with APK Studio

If you’ve ever modified precompiled applications, you have undoubtedly spent … more

TasGear: A Tasker Extension for the Samsung Galaxy Gear

With wearable technology taking center stage this year, one can only expect more … more

Intelligently Place Contacts on Your Home Screen with CallWho Widget

There are plenty of ways to get your contacts to show up on your … more