5,597,198 Members 43,489 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Xperia T won't turn on or charge

Tip us?
 
otmane14
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Dec 2013
Default [Q] Xperia T won't turn on or charge

Hi everyone ! I bought an xperia T two months ago, everything was perfect until this morning ! I was listenning to my music suddenly the phone turned off and when i tried to turn it on nothing happened ! I tried to hold the volume+ button and the power button but no vibrations or led light. I can't use flashtool because the phone can't boot on flashmode ! I plugged the phone on charge for several hours but nothing ! I really need some help because i can't send it back to sony !
 
otmane14
Old
#2  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Dec 2013
Please guys i need help cuz i can't afford buying a new phone !
 
hhamzah49
Old
#3  
hhamzah49's Avatar
Senior Member
Thanks Meter 31
Posts: 221
Join Date: Mar 2013
Location: Den Haag
try pressing the power button while putting it on a charge. if it vibrates or a led comes it still is alive. If that doesnt work try a rubber band around the power button and then on the charge for 24 hours.
The Following User Says Thank You to hhamzah49 For This Useful Post: [ Click to Expand ]
 
otmane14
Old
#4  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Dec 2013
Quote:
Originally Posted by hhamzah49 View Post
try pressing the power button while putting it on a charge. if it vibrates or a led comes it still is alive. If that doesnt work try a rubber band around the power button and then on the charge for 24 hours.
My phone is on charge now for 14 hours ! What should i do exactly in this situation ?
 
hhamzah49
Old
#5  
hhamzah49's Avatar
Senior Member
Thanks Meter 31
Posts: 221
Join Date: Mar 2013
Location: Den Haag
Quote:
Originally Posted by otmane14 View Post
My phone is on charge now for 14 hours ! What should i do exactly in this situation ?
If its on charge get it off the charge and try vol+ and power button and hold it for a half minute till you feel vibrate. if you dont see the vibration.
If that doesnt work get it off the charge and try pressing power button and then put the usb in.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes