5,603,858 Members 40,303 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Soft bricked HTC One mini, any solution or am I screwed?

Tip us?
(Last edited by STEAKTASTIC; 27th December 2013 at 11:43 PM.) Reason: update title
Junior Member - OP
Thanks Meter 1
Posts: 12
Join Date: Dec 2013
Prompt [Q] Soft bricked HTC One mini, any solution or am I screwed?

OK so I've been researching for days how to unlock boot loader, root and s-off my HTC one mini. I bought the phone in november so im assuming that i updated to 4.3 or it was already installed (relevant later). I htcdev unlocked my boot loader, installed twrp and made a backup, installed superuser and rooted my phone. Then I installed titanium backup pro, made a backup and uninstalled all the system apps/bloatware I didn't need. All was peachy but the apps kept reappearing which I found was down to s-on (despite what I read about htcdev unlock boot loader method making my phone s-off) . So I tried the revone method and got error 1 which apparently is down to having android 4.3 so I looked for an earlier ROM and flashed Magio r1 which worked fine but couldn't find the data/local/temp folder to install revone into. Probably could of put it somewhere else but I wasn't that confident with the s-off process. So I finally found Jmz m4 stock ROM so there was light at end of tunnel. So I read up on twrp factory reset/format data functions and saw people were using both methods. I went with the full format and factory reset afterwards. Looking back now that was pretty stupid as I have no ROM and no backups to restore to. I did manage to chmod 777 the permissions on my twrp backups and copy the to dropbox (after endless scouring of forums). I also know how to flash boot images and use the adb side load functions. So that's my story.

Problem is I can't adb push the file as it returns with error closed, I've tried the following commands:

adb device - my device is attached and side loading.
adb usb - returns error closed

adb kill-server
adb start server - server starts successfully then returns error closed.

adp push rom.zip /data/media/0 - returns error closed

And just to be sure I tried with /data/media/, same error

I've fastboot flashed the jmzM4 ROM image and kernel but no joy as I'm guessing the boot image isn't enough and you need the zip.

If anyone can help out that would be greatly appreciated.

Currently I can load into boot loader and recovery no problem, just freezes on HTC load screen in normal boot up.
Junior Member
Thanks Meter 0
Posts: 2
Join Date: Sep 2012
Default did you repair it?


Did you managed to repair it? because i have the same problem...
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes