5,599,677 Members 45,492 Now Online
XDA Developers Android and Mobile Development Forum

Amaze 4G mic problem

Tip us?
 
DCF1942
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Mar 2010
Audio Amaze 4G mic problem

My Amaze 4G for T-Mobile was rooted with s-on and flashed with Revolution HD 4.0 about half year ago. I had to change the digitizer/LCD assembly because it went dark. That went rather smoothly. However, the mic stopped working after that. I can hear people but they can't hear me. I did re-flash with the same ROM after the repair since the phone was having some other issues I thought might be software related. Didn't test the mic before the flash though.

The symptoms and what I've done so far:

-- People can't hear me during call. Turning on speaker doesn't help. Using a headset with built-in mic works.
-- The voice recorder app can't record a thing. Tapping the phone doesn't record either, so it's not dirt blocking the hole. AndroSensor app shows no sound input.
-- I can record video WITH sound. This was actually done after I replaced the mic PCB. Does this mean the mic is OK or the phone has another mic?
-- Re-flashed and tried another ROM, same thing.
-- Flashed back to stock T-Mobile ICS ROM, no good.
-- Installed SoundAbout app, played around with it, i.e., the headset plug trick, still no dice.

Since I can record video with sound, I feel it's more like a software problem, unless there's a secondary mic used for video recording but not phone calls. The sound doesn't seem to be recorded through the mic hole at the bottom as blocking it with my finger doesn't reduce the volume. I'm thinking to try the stock Gingerbread ROM as a last resort.

Any input will be greatly appreciated.
 
pbergonzi
Old
#2  
Senior Member
Thanks Meter 55
Posts: 143
Join Date: Jun 2013
Location: San Pedro
Quote:
Originally Posted by DCF1942 View Post
My Amaze 4G for T-Mobile was rooted with s-on and flashed with Revolution HD 4.0 about half year ago. I had to change the digitizer/LCD assembly because it went dark. That went rather smoothly. However, the mic stopped working after that. I can hear people but they can't hear me. I did re-flash with the same ROM after the repair since the phone was having some other issues I thought might be software related. Didn't test the mic before the flash though.

The symptoms and what I've done so far:

-- People can't hear me during call. Turning on speaker doesn't help. Using a headset with built-in mic works.
-- The voice recorder app can't record a thing. Tapping the phone doesn't record either, so it's not dirt blocking the hole. AndroSensor app shows no sound input.
-- I can record video WITH sound. This was actually done after I replaced the mic PCB. Does this mean the mic is OK or the phone has another mic?
-- Re-flashed and tried another ROM, same thing.
-- Flashed back to stock T-Mobile ICS ROM, no good.
-- Installed SoundAbout app, played around with it, i.e., the headset plug trick, still no dice.

Since I can record video with sound, I feel it's more like a software problem, unless there's a secondary mic used for video recording but not phone calls. The sound doesn't seem to be recorded through the mic hole at the bottom as blocking it with my finger doesn't reduce the volume. I'm thinking to try the stock Gingerbread ROM as a last resort.

Any input will be greatly appreciated.
Since the Amaze records video in stereo, I have to assume there are at least 2 mics.
Amaze 4G Unlocked Rooted S-off (Juopunutbear) SuperCID 4EXT CM10

This is not haiku.
Nor does it profess to be.
Android in Springtime.
 
DCF1942
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Mar 2010
Quote:
Originally Posted by pbergonzi View Post
Since the Amaze records video in stereo, I have to assume there are at least 2 mics.
Make sense. It was working fine before I changed the digitizer/LCD. Thought I might broke something during the process. Checked the cables and they looked OK, so I replaced the microphone PCB but that didn't help. Could be a bad PCB though. May try to ask seller for a replacement. Does the problem sound like a software issue to anyone? I went ahead re-flashed the stock GB ROM but failed. I read somewhere the phone needs to be S-Off to do that. Any suggestions what else I can try to fix it?
 
pbergonzi
Old
#4  
Senior Member
Thanks Meter 55
Posts: 143
Join Date: Jun 2013
Location: San Pedro
Quote:
Originally Posted by DCF1942 View Post
Make sense. It was working fine before I changed the digitizer/LCD. Thought I might broke something during the process. Checked the cables and they looked OK, so I replaced the microphone PCB but that didn't help. Could be a bad PCB though. May try to ask seller for a replacement. Does the problem sound like a software issue to anyone? I went ahead re-flashed the stock GB ROM but failed. I read somewhere the phone needs to be S-Off to do that. Any suggestions what else I can try to fix it?
Not a notion. It would be nice if there was some sort of schematic or youtube how-to for the mic. As for getting to S-Off, there is guide if necessary--do a search.
Amaze 4G Unlocked Rooted S-off (Juopunutbear) SuperCID 4EXT CM10

This is not haiku.
Nor does it profess to be.
Android in Springtime.
 
DCF1942
Old
#5  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Mar 2010
Quote:
Originally Posted by pbergonzi View Post
Not a notion. It would be nice if there was some sort of schematic or youtube how-to for the mic. As for getting to S-Off, there is guide if necessary--do a search.
Replacing the mic PCB was easy, figured it out by myself. Can't be sure if I broke something else during the repair. I did search for S-Off guides and it seems the wire trick under Linux is the only way to go now. Since putting back the stock ICS ROM didn't help, I don't think the stock GB ROM will do any good either. The phone had ICS when I rooted it. Requested a replacement of the mic PCB I bought, let's see how that goes.
 
pbergonzi
Old
#6  
Senior Member
Thanks Meter 55
Posts: 143
Join Date: Jun 2013
Location: San Pedro
Quote:
Originally Posted by DCF1942 View Post
Replacing the mic PCB was easy, figured it out by myself. Can't be sure if I broke something else during the repair. I did search for S-Off guides and it seems the wire trick under Linux is the only way to go now. Since putting back the stock ICS ROM didn't help, I don't think the stock GB ROM will do any good either. The phone had ICS when I rooted it. Requested a replacement of the mic PCB I bought, let's see how that goes.
Good luck.
Amaze 4G Unlocked Rooted S-off (Juopunutbear) SuperCID 4EXT CM10

This is not haiku.
Nor does it profess to be.
Android in Springtime.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


XDA PORTAL POSTS

A More Competitive Spin on the Addictive 2048 Puzzle

You may recall that a few weeks ago, we talked about a rather interesting take on … more

Multiboot in Progress for the Sony Xperia Z1

As we’ve mentioned quite a few times in the past, multiboot is quite the interesting … more

Samsung EFS Tool Updated to V5, Brings Universal Device Support

You may recall that we’ve talked about XDA Recognized Contributor … more

Say Goodbye to Holo Blue Once and for All

When Google released Android 4.4 KitKat back in October of last year, they changed quite a bit … more