open the superuser application hit menu, then preferences, there should be a selection to toggle notifications, toggle it to off.

for supersu, open the app, hit menu, then settings, there is a selection to toggle notifcations, toggle it to off.