Unhappy [Q] After 2 Different root now screen touching don't work.

i hope, i can find a solution for my problem because technically my "nook simple touch" is turn to brick.
my button work but screen don't answer to touch. (from only screensaver screen, it works)

i write: what i do by order.
1- i install "root" by nookmanager without 1.2.1 update: everything was good but i saw "touchnooter"
2- system upgrate yourself to 1.2.1
3- i unregister inside of nook. so "root" deleted
4- i install "TouchNooter" but i can't pass "nook starting up" screen.
5- i recover fabric.zip by nookmanager, system return 1.1.2
6- this time i download "nook_1_2_update.zip" and upgrade system 1.2.1 manually.
7- i "root" by nookmanager again.
8- this time i install market by "NTGAppsAttack package"
9- pass the "searching" and i close market (not work yet)
10- install "1MobileMarket_h.apk" for mobile market. (it was work last root)
11- i left nook in charge 1mobilemarket screen.

two hour later screen did not worked so i reset nook. now screen dont answer touching. as connect usb cable to computer. but when i touch in lookscreen, it is open with touch. so hardware work.
Now "slidelock" screen don't come. when i connect computer "usb connected" screen don't come.

i try
1- fabric.zip with nookmanger
2- n2T-Recovery_0.2, it F..k the screen (flashes)
3- fabric.zip again. nothing change
4- n2T-Recovery_0.1 nothing change
5- with "128mb_clockwork-rc2" delete, recover fix boot try everything nothing change
6- i install touchnooter again. this time it succes but only first screen and "back" button worked. and flashes problem solved
7- after recovery i install nookmanager. both root work together. but still touching don't work.
8- by "128mb_clockwork-rc2" delete everything
9- update 1.2.1. still don't work.

What can i do more, fix this problem?