Question [Q] HELP 4.4.2 Update Error "/system/bin/debuggerd" has unexpected contents

Hello guys. I'm new here and I hope you can help me with my update problem:

I'm using ASUS Google Nexus 7 2012 rooted running Android 4.4 KitKat KRT16S

the problem is when I update it default through OTA in the device itself, when i reboot it, it still not 4.4.2 but the system says I'm running the latest version of android.

i tried manually using TWRP recovery but i get this error

Updating partition details...
Installing '/sdcard/!ReadyToFlash/Root_Files/kk.zip'...
Checking for MD5 file...
Skipping MD5 check: no MD5 file found.
Verifying current system...
"/system/bin/debuggerd" has unexpected contents.
E:Error executing updater binary in zip '/sdcard/!ReadyToFlash/Root_Files/kk.zip
Error flashing zip '/sdcard/!ReadyToFlash/Root_Files/kk.zip

Note: !ReadyToFlash is the folder where the kk.zip which is the OTA file is located

I hope somebody here can help me or give me a link of the right debuggerd file. Thanks you very much.