5,600,053 Members 42,528 Now Online
XDA Developers Android and Mobile Development Forum

[Solved] GT-I9205 Stuck At Boot Animation

Tip us?
 
dynomist
Old
(Last edited by dynomist; 4th January 2014 at 10:06 AM.) Reason: Additional Note
#1  
Member - OP
Thanks Meter 41
Posts: 48
Join Date: Dec 2013
Question [Solved] GT-I9205 Stuck At Boot Animation

Hi,

Currently I'm compiling OmniRom for Samsung Galaxy Mega GT-I9205.

When I try to boot it for the first time, the Omni is stuck at the boot animation...
May I know what is the general failure for this particular issue? and how to solve it?

logcat F/
Code:
12-29 19:01:06.722 F/MediaProfiles(  287): frameworks/av/media/libmedia/MediaProfiles.cpp:324 CHECK(quality != -1) failed.
12-29 19:01:06.722 F/libc    (  287): Fatal signal 6 (SIGABRT) at 0x0000011f (code=-6), thread 287 (zygote)
logcat /E
Code:
12-29 19:01:07.513 E/QualcommCamera(  754): Qint android::get_number_of_cameras(): E
...
12-29 19:01:07.513 I/AudioPolicyManagerBase(  754): loadAudioPolicyConfig() loaded /system/etc/audio_policy.conf
12-29 19:01:07.523 D/ALSADevice(  754): ALSA module opened
12-29 19:01:07.533 D/AudioHardwareALSA(  754): AudioHardware: DLOPEN successful for ACDBLOADER
12-29 19:01:07.533 D/ACDB-LOADER(  754): ACDB -> ACDB_CMD_INITIALIZE
12-29 19:01:07.533 E/        (  754): [ACDB RTC]->rtc init done!->result [0]
12-29 19:01:07.533 E/Diag_Lib(  754): actp_diag_init: call diag init function with B5F20ECD
12-29 19:01:07.533 E/Diag_Lib(  754):  Diag_LSM_Init: Failed to open handle to diag driver, error = 13
12-29 19:01:07.533 E/Diag_Lib(  754): actp_diag_init: diag init failed
12-29 19:01:07.533 E/        (  754): [ACDB ACPH]->actp diag init done!
---

I suspect the media_profiles.xml is corrupted... but nope...
anywhere this is the comparison of media_profiles.xml between
melius >> https://github.com/Grarak/android_de...a_profiles.xml
hammerhead >> https://github.com/omnirom/android_d...a_profiles.xml
Diff >> http://diffchecker.com/ghjvhy51

and the device mk file
Code:
https://github.com/Grarak/android_device_samsung_melius-common/blob/android-4.4/melius-common.mk
# Media Profile
PRODUCT_COPY_FILES += \
    $(LOCAL_PATH)/media/media_profiles.xml:system/etc/media_profiles.xml
# Note: Didnt have media_codecs.xml
Code:
https://github.com/omnirom/android_device_lge_hammerhead/blob/android-4.4/device.mk
PRODUCT_COPY_FILES += \
    device/lge/hammerhead/media_codecs.xml:system/etc/media_codecs.xml \
    device/lge/hammerhead/media_profiles.xml:system/etc/media_profiles.xml
Attached Files
File Type: zip I9205-logcat.zip - [Click for QR Code] (140.4 KB, 14 views)
 
XpLoDWilD
Old
#2  
XpLoDWilD's Avatar
Senior Recognized Developer
Thanks Meter 14035
Posts: 1,585
Join Date: Nov 2009
Location: France

 
DONATE TO ME
Try using hammerhead (or another closer similar Qcom device)'s media_codec.xml and media_profiles.xml (or remove those files)
_ Omni developer - Android - Check my twitter for the latest updates!
______
<codeworkx> YIPIJAHEY SCHWEINEBACKE

Samsung Galaxy S II i9100, Galaxy Note N-7000, Galaxy S III i9300 Asus TF300T, TF700T Sony Xperia T (mint) LG Nexus 4, Nexus 5 Oppo Find 5, N1
and other devices you've never heard of.
______
Press "Thanks" if I helped !
 
dynomist
Old
#3  
Member - OP
Thanks Meter 41
Posts: 48
Join Date: Dec 2013
Thank your for the suggestion... look like i have to test on hammerhead xml afterall

but b4 that,
Im hoping someone able to tell me the logcat diagnostic
coz this file is currently used in CM11 (I9205) and they didnt have issue for this particular matter
 
dynomist
Old
#4  
Member - OP
Thanks Meter 41
Posts: 48
Join Date: Dec 2013
Great news...
I managed to get it working... now omnirom have another working device in his pocket

Solutions: use media codec + profile from hammerhead... media codec + profile by touchwiz wont work
---

but i still have some problem
i able to get the camera to work, but the video recording is recording black screen...
Tags
gt-i9205, i9205, melius, meliuslte, meliusltexx
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes