Default [Q] [Fixed] MTK6589 - Flashtool readback killed BT/Wifi/GPS

Hello,
I've bought a new device - Evolveo StronPhone Q4, MTK6589 based phone. The stock ROM is basically vanilla Android 4.2.1. I've successfully rooted it using Framaroot.
Then I've created scatter file using MTK Droid Tools (all partitions that were formated were ext4).
Then I've decided to create a backup before I start playing with it, so I've tried backing up flash using SP Flash Tool (using Readback), it was running fine and downloaded approx. 20%, then crashed. I've tried that once or twice more times, always failed. Now after I plug it in, windows display "This device can perform faster" and FlashTool won't detect the device. If I connect it without battery with VolDn key pressed, FlashTool detects it and I get S_DL_GET_DRAM_SETTING_FAIL.
However, the phone boots fine, just GPS/Wifi/BT is not working. (No GPS icon appers, and I get errors like BT_open: WMT turn on BT fail in dmesg). Looks like an issue with kernel/HW issue.
Any ideas what could have gone wrong and how to fix it?
In the meantime, I've asked manufacturer for a stock FW image, but I'm not sure it helps...



Update: Okay, I have no clue what just happened. However I've unrooted, reverted everything I've modified on the phone so far so I'll be able to return it to manufacturer as "deffective"... And just for the curiosity connected it to the computer and tried downloading ROM one more time. And it succeeded - I'll upload the ROM once I get access to faster internet connection. I've removed the battery (phone was stuck in Preloader mode because I cancelled ongoing RAM test.), put it back and now everything works.
So, it looks like everything is fine now, however I'd love to know what happened, if you have any clue, please let me know!