5,594,151 Members 46,319 Now Online
XDA Developers Android and Mobile Development Forum

[Q] TWRP won't install on rooted device

Tip us?
 
NovaSupreme
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 2
Join Date: Dec 2013
Location [Q] TWRP won't install on rooted device

I have xperia s (st25a) phone with android 4.0.4.

I already have rooted it (SU installed) and bootloader unlocked. Fastboot reports the correct version "5".

However, when I try to install TWRP, it gives the following error:

>fastboot.exe flash boot stock-6.1.A.0.452-twrp-2.4.0.0.elf
sending 'boot' (8124 KB)...
FAILED (remote: The Device must be rooted first)

Why does TWRP think it's not rooted? I have setup SU to grant every root request too!

Another issue - when I try to enter recovery with stock image, my phone gets stuck on boot with Sony logo and I have to remove battery to shut it down. Any ideas why wouldn't stock recovery work?

Thanks much for your help!
 
NovaSupreme
Old
#2  
Junior Member - OP
Thanks Meter 0
Posts: 2
Join Date: Dec 2013
Default Help!

Any one has any ideas to try?

Quote:
Originally Posted by NovaSupreme View Post
I have xperia s (st25a) phone with android 4.0.4.

I already have rooted it (SU installed) and bootloader unlocked. Fastboot reports the correct version "5".

However, when I try to install TWRP, it gives the following error:

>fastboot.exe flash boot stock-6.1.A.0.452-twrp-2.4.0.0.elf
sending 'boot' (8124 KB)...
FAILED (remote: The Device must be rooted first)

Why does TWRP think it's not rooted? I have setup SU to grant every root request too!

Another issue - when I try to enter recovery with stock image, my phone gets stuck on boot with Sony logo and I have to remove battery to shut it down. Any ideas why wouldn't stock recovery work?

Thanks much for your help!
 
polobunny
Old
#3  
polobunny's Avatar
Senior Member
Thanks Meter 2118
Posts: 5,451
Join Date: Oct 2011
Location: Montreal
You would have more luck in your device respective subforum.
http://forum.xda-developers.com/xperia-s
Please press THANKS if someone helps you!

My current configuration:
 

Device: Samsung Galaxy S3 SGH-i747M
ROM: cm-11-20140413-NIGHTLY-d2lte
Kernel: Stock
Baseband: I747MVLUEMF1
Bootloader: I747MVLDMF1
Governor: Interactive


Older device: Nexus S i9020A
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes