5,595,815 Members 36,668 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Trouble with Widgets on ViperOne (4.0.1 and 4.1.0)

Tip us?
 
TheGStreets
Old
#1  
Junior Member - OP
Thanks Meter 2
Posts: 6
Join Date: Dec 2013
Thumbs up [Q] Trouble with Widgets on ViperOne (4.0.1 and 4.1.0)

I have a HTC One with the following config

ROM: ViperOne 4.1.0
Kernel: ElementalX
Recovery: TWRP 2.6.3.4

I have been having troubles with some widgets/apps recently. ON the MainScreen.. when we do a long press and then the app widget screen comes below.. you can drag apps/widgets/shortcuts and place them on the main screen, however for me most of the widgets aren't working. I was recently on ViperOne 1.0.1 with unknown firmware and recovery and stock kernel, and it used to work JUST fine there. I recently upgraded and even did the OTA update of recent 4.1.0 hoping it will fix the issue but it din't.
Below is the details of the widgets/apps that don't work:

1. Twitter4x2, 4x1 both)
When I click on these, it will open the "Display" settings asking between two options (radio buttons) > "Tweets" & "Mentions". None of them works.

2. App & Shortcut(1x3)
When I click this one, it will open "Tap a shortcut to assign an app" along with the 4 "+" signs that we can click and add apps/shortcuts to, when I do either(app or shortcut) it won't add to the "+" sign and nothing happens. I clicked ok and it just kinda throws me back on the mainscreen without any changes or any trace of the widget

As you can see there are tonnes, i will just name the app and its size now:
Android Assistant(1x1, 4x1, 4x2), BBM(4x4), Notes widget(4x4), Titanium Backup(1x1), Analog Clock[or any other clock widget for that matter](1x1, 2x1, 4x1, 4x2), weather(4x1, 2x1, 1x1).

Some of these do work like the AirDroid widget and a couple others. Please help?

{Special thanks to Kamil Mirza to walk me through step by step and helping me understand the importance and meaning of most things in Android Development world including rooting and such, also for trying to help me fix the issue!!!!
The Following User Says Thank You to TheGStreets For This Useful Post: [ Click to Expand ]
 
kamilmirza
Old
#2  
kamilmirza's Avatar
Senior Member
Thanks Meter 241
Posts: 1,033
Join Date: Dec 2011
Location: Lahore
reflash the ROM
hit the THANKS button if helped
Google Nexus 5
The Following User Says Thank You to kamilmirza For This Useful Post: [ Click to Expand ]
 
haran_rulez
Old
#3  
Senior Member
Thanks Meter 64
Posts: 220
Join Date: Sep 2008
Quote:
Originally Posted by TheGStreets View Post
I have a HTC One with the following config

ROM: ViperOne 4.1.0
Kernel: ElementalX
Recovery: TWRP 2.6.3.4

I have been having troubles with some widgets/apps recently. ON the MainScreen.. when we do a long press and then the app widget screen comes below.. you can drag apps/widgets/shortcuts and place them on the main screen, however for me most of the widgets aren't working. I was recently on ViperOne 1.0.1 with unknown firmware and recovery and stock kernel, and it used to work JUST fine there. I recently upgraded and even did the OTA update of recent 4.1.0 hoping it will fix the issue but it din't.
Below is the details of the widgets/apps that don't work:

1. Twitter4x2, 4x1 both)
When I click on these, it will open the "Display" settings asking between two options (radio buttons) > "Tweets" & "Mentions". None of them works.

2. App & Shortcut(1x3)
When I click this one, it will open "Tap a shortcut to assign an app" along with the 4 "+" signs that we can click and add apps/shortcuts to, when I do either(app or shortcut) it won't add to the "+" sign and nothing happens. I clicked ok and it just kinda throws me back on the mainscreen without any changes or any trace of the widget

As you can see there are tonnes, i will just name the app and its size now:
Android Assistant(1x1, 4x1, 4x2), BBM(4x4), Notes widget(4x4), Titanium Backup(1x1), Analog Clock[or any other clock widget for that matter](1x1, 2x1, 4x1, 4x2), weather(4x1, 2x1, 1x1).

Some of these do work like the AirDroid widget and a couple others. Please help?

{Special thanks to Kamil Mirza to walk me through step by step and helping me understand the importance and meaning of most things in Android Development world including rooting and such, also for trying to help me fix the issue!!!!
Did you do a full wipe before flashing the latest Viper version? Try to use the TWRP 2.6.3.3 version. Some users have reported problems with upgraded version. Not that the above things will solve the issue, you could give a shot. Never know it might work..

Sent from my HTC One using xda app-developers app
The Following User Says Thank You to haran_rulez For This Useful Post: [ Click to Expand ]
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes