5,593,248 Members 32,444 Now Online
XDA Developers Android and Mobile Development Forum

[Q] S4 Touch not responding

Tip us?
 
Sezyrrith
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 2
Join Date: Oct 2013
Default [Q] S4 Touch not responding

I picked up my S4 from Best Buy and got the insurance plan on it. A few weeks back, I dropped it, and the touch screen stopped responding. A simple reboot did not fix it. When I took it in, the Geek Squad guy took a look at it, then it looked like he booted it into recovery (though I didn't see exactly what he did) and did something there that fixed it without a factory reset. He gave a really quick runthrough of what he did, but since I wasn't the one doing it myself, I don't remember what he said.

Anyone here know what it might have been? It's happened again, and I tried recovery and clearing the cache, but that didn't help, and I didn't see any other options that a person free-standing in a room would use to fix something (no updates to apply from cache etc. and I tried clearing the cache to no avail) and I'm hoping to avoid having to either take it apart or *shudder* deal with a flip phone loaner for a few days while I wait for a replacement.
 
graydiggy
Old
#2  
graydiggy's Avatar
Recognized Contributor
Thanks Meter 1932
Posts: 4,024
Join Date: Sep 2011
Location: Houma, LA

 
DONATE TO ME
You need a replacement... Bottom line. They should trade it out in store.

Sent from my SAMSUNG-SGH-I337 using XDA Premium 4 mobile app
Lost in a paper bag again...
 
Sezyrrith
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 2
Join Date: Oct 2013
Quote:
Originally Posted by graydiggy View Post
You need a replacement... Bottom line. They should trade it out in store.

Sent from my SAMSUNG-SGH-I337 using XDA Premium 4 mobile app
Actually, this morning my alarm was going off, and I had no way of turning it off (no touch, and wouldn't respond to 'stop' voice command) so I took the battery out for the 5th or 6th time. When I replaced it, upon booting up, the phone worked again. *shrug* Whatever was out of place or not working has now temporarily rectified itself. I'll probably have them replace it next time it comes up anyway, assuming it happens again.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes