Unhappy [Q] Celkon A119Q - MT6589 CWM:E: Error Cant open Cache/Recovery Log - Possible Brick?

Hello Developers

Yesterday, i tried to do a CWM back up of my ROM and it stopped in the middle with below errors

E:Can't open/cache/recovery/log
E:Can't open /cache/recovery/log
[Read Only File System
E:Can't open /cache/recovery/last_log
E:Can't open /cache/recovery/last_log

I Know there are many threads with this question, however mine is litte different; How?

1. I am able to mount my SD CARDs to PC
2. ADB works fine
3. Format Cache - Works fine
4. Wipe / Factory Data Reset - Works fine
5. Format System Works Fine
6. Wipe Dalvik Cache - Exits without any error

When the system reboots, I get a message "ENCRYPTION UNSUCCESSFUL" Reset phone, when clicked on Reset, phone reboots into Recovery.

ADB works fine, but i am not able to use Flash_image - Error Message file not found [it was placed in root of the memory card]
Tried to flash recovery through SP flash tools, i get an error Message - SDA SDMMC write failed

MTK Root tool does not recognize phone.

Please let me know if this is a permanent brick or is there any work around to resolve this.

My phone is only 6 months old, but cannot claim warranty because of CWM and Boot logo changed