Default [Q] TWRP for Korean G2 F320S

I saw the new version of TWRP for g2 thread by WACOMalt in g2 Android development section
And I clicked the ljnk for Korean g2 there's only 2.6.3.2 version and I went to other device section F320S that I'm using there's only 2.6.3.2 available as well
Is korean version of TWRP not supported?
Since Korean versions of G2 got updated to Kitkat 4.4 the older version of CWM does not work anymore
So we need some other recovery or new version to.make it work