5,603,981 Members 43,652 Now Online
XDA Developers Android and Mobile Development Forum

[Q] EBR missing in T699

Tip us?
 
scopedial
Old
(Last edited by scopedial; 23rd December 2013 at 12:59 AM.) Reason: adding logcat output
#1  
Junior Member - OP
Thanks Meter 0
Posts: 23
Join Date: Nov 2013
Prompt [Q] EBR missing in T699

Some of you may be familiar with my trials with my T699. To make a long story short, (see that story here http://forum.xda-developers.com/show....php?t=2528444) (thanks gee one!)
I was attempting to put CM on my Relay and I ended up hard bricking it.
I can now boot but I need a SD card installed to do it.

Recently I was playing around with adb and was running logcat which dumped a whole mess of wonderful information.
The line I thought was important was the following -

I/rmt_storage( 125): No EBR found

It is my guess that I messed up (corrupted) the EBR and that is why I am dependent on the external SD card.

My question is, does anyone know how to restore the EBR to working condition? I have tried to use odin to put the stock
image on but I think it is just over-writing the image on the SD card. If it can be done using adb that would be very great too since
it appears to be working well.

Oh, and the other thing I noticed, if I do not put the SD card, with image, into the slot I just boot into QHSUSB-DLOAD mode.
Which means much but is not useful at this time.

Thanks all,

Lou


I have added the first 25 lines of the logcat -

--------- beginning of /dev/log/main
I/rmt_storage( 125): Target is APQ8064: 1074445686
I/rmt_storage( 125): No EBR found
I/rmt_storage( 125): Error (-1) parsing MBR partitions
I/rmt_storage( 125): Registering modemst1: 0x4a /boot/modem_fs1
I/rmt_storage( 125): Registering modemst2: 0x4b /boot/modem_fs2
I/rmt_storage( 125): Registering fsg: 0x58 /boot/modem_fsg
I/rmt_storage( 125): Registering ssd: 0x5d ssd
I/rmt_storage( 125): 4 GPT partitions found
D/ICD ( 183): icd .02 runs
E/DataRouter( 186): Main entered
E/DataRouter( 186): switchUser
E/DataRouter( 186): monitor_usb_thread
E/DataRouter( 186): server_init
E/DataRouter( 186): Opening of the usb select file failed fd is -1 & errno is 2
E/DataRouter( 186): Opening of the usb select file failed fd is -1 & errno is 2
E/DataRouter( 186): Initialise USB and start the thread
E/DataRouter( 186): dr_usb_init
E/DataRouter( 186): USB Interface is open with 0x9
E/DataRouter( 186): USB interface is now configured for usb_fd = 0x9
E/DataRouter( 186): THREAD LAUNCH
E/DataRouter( 186): monitor_data_of_usb
E/DataRouter( 186): USB monitor thread launched, usb_fd= 0x9
E/DataRouter( 186): init_cur_sock
E/DataRouter( 186): Before the usb select
I/DEBUG ( 182): debuggerd: Mar 16 2013 22:15:51




*** UPDATE ***
I found another interesting line in line in the logcat ...

W/PackageManager( 674): Library not found: /system/framework/com.qualcomm.location.quipslib.jar
 
scopedial
Old
(Last edited by scopedial; 2nd January 2014 at 07:40 PM.) Reason: update
#2  
Junior Member - OP
Thanks Meter 0
Posts: 23
Join Date: Nov 2013
Prompt More on de-bricking

I have been continuing my hunt on how to permanently de-brick my T699. The following thread does not leave me with
much hope . I know it is for Evita on the HTC One but I see similar behaviour when I hook my T699 to linux.

http://forum.xda-developers.com/show...966850&page=40

If anyone can comment on this it is greatly appreciated.
Tags
android, boot, mbr, relay, t699
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes