5,597,138 Members 44,996 Now Online
XDA Developers Android and Mobile Development Forum

[SOLVED] "'Firmware upgrade encountered an issue." Softbrick issue

Tip us?
 
Dakar-A
Old
(Last edited by Dakar-A; 3rd January 2014 at 02:04 AM.) Reason: Solved issue, edited title to reflect that.
#1  
Junior Member - OP
Thanks Meter 0
Posts: 2
Join Date: Jan 2014
Exclamation [SOLVED] "'Firmware upgrade encountered an issue." Softbrick issue

Hello XDA!

So, idiot that I am, I decided today would be a great time to root my Galaxy S III (SGH-T999N version). It was running Jellybean 4.3, so it had fewer root options than other, older Jellybean versions, but I still found a root file on here. I put it into USB debugging mode, downloaded the driver, Odin, and the root file. I also backed the phone up on Kies, and have that on my PC., I did everything right, and... it failed. I tried again without doing anything to the phone (read: kept it in download mode), but it failed again with a different root file. So, I turned it off, sad that I wasn't able to root it, and I came upon the dreaded 'Firmware upgrade encountered an issue. Please select recovery mode in Kies & try again' screen.

After hours of searching, I saw two different solutions: downloading the 4.3 OS from online, and using Odin to flash that to the phone, or using Kies to reformat the phone. I've been trying Kies, but Kies 3 isn't recognizing the phone, and won't allow me to restore or to reformat the phone. I'm still waiting on the download of Jellybean 4.3 to finish so that I can try that (Odin HAS been recognizing the phone). While I wait, I wanted to know if other users have had similar problems that they've solved, or where I've gone wrong, and what I can fix.

As for additional details:

- I CAN put the phone into Download mode. I CANNOT do a factory reset through Vol. Up+Home+Power
- The status screen with 'Firmware upgrade encountered an issue. Please select recovery mode in Kies & try again' also has this information at the top:

ODIN MODE
PRODUCT NAME: SGH-T999N
CUSTOM BINARY DOWNLOAD: Yes (1 counts)
CURRENT BINARY: Custom
SYSTEM STATUS: Official
QUALCOMM SECUREBOOT: ENABLE
Warranty Bit: 0
BOOTLOADER AP SWAREV: 1


- The phone is carried by Metro-PCS

Thanks in advance!
 
Dakar-A
Old
#2  
Junior Member - OP
Thanks Meter 0
Posts: 2
Join Date: Jan 2014
Okay, turns out the downloaded Jellybean 4.3 OS did the trick. For future people who run into this issue:

1. Have Odin 3.07 or higher downloaded (Odds are that you have this due to your phone's current state).

2. Download a copy of the OS you want from here: samsung-updates.com/device/?id=SCH-I535 Go to the dropdown menu on the left-hand side, and select your phone. Don't know/remeber your phone's identifier? Open up the back, remove the battery, and there should be a white sticker with your phone's model at the top. WARNING! Unless you plan to pay, these downloads will take a while. Do this when you can have your computer on for 4+ hours.

3. Once the download is complete, unzip the file, and place it in a location that you can easily find with Odin.

4. Open Odin, and make sure that Auto Reboot and F. Reset time are the only options checked. If there are other options selected, uncheck them and proceed.

5. Click the "PDA" button, and select your copy of the Android OS from where it was stored. Assuming everything has gone correctly, a message should appear in the Odin status box along the lines of "Check MD5... Do not unplug the cable...". Wait for the message "Leave CS..." to appear before proceeding.

6. Once "Leave CS..." has appeared, put your phone into Download mode (Turn it off, then restart by holding down the Vol. Down, Home, and Power keys until you get a screen that has informed you that you are in download mode.). Then, plug your usb cable into your PC/Laptop, and then into the USB outlet on the phone.

7. Once Odin has noted that your phone is attached, you can press "Start", and assuming all steps have been followed correctly, the new OS should download, and your phone will reboot, fully functional. If you are lucky like me, it will even have kept all of your settings!
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes