Post Reply

droid 4 battery won't charge

OP joeynshelby

4th January 2014, 05:25 AM   |  #1  
OP Junior Member
Thanks Meter: 2
 
16 posts
Join Date:Joined: Feb 2011
Donate to Me
More
I took the battery out of my droid 4 to replace my broken digitizer. I put the battery back in and now it won't charge. It goes from 5% to 100% and shuts off. Phone is dead. I bought one of the factory adapters from teamblackhat. When I attach it to the computer it boots up fine. Any suggestions to get it charging again?
4th January 2014, 09:12 AM   |  #2  
Senior Member
Flag Frodsham, Cheshire, UK
Thanks Meter: 32
 
1,388 posts
Join Date:Joined: Dec 2005
More
Quote:
Originally Posted by joeynshelby

I took the battery out of my droid 4 to replace my broken digitizer. I put the battery back in and now it won't charge. It goes from 5% to 100% and shuts off. Phone is dead. I bought one of the factory adapters from teamblackhat. When I attach it to the computer it boots up fine. Any suggestions to get it charging again?

I've seen this behaviour with batteries before. Not sure if it's due to damage or not, but I've found that a) they sometimes work fine in different phones, and b) are replacement battery seems to fix the problem.

Cheers,

Steve.
4th January 2014, 09:35 AM   |  #3  
OP Junior Member
Thanks Meter: 2
 
16 posts
Join Date:Joined: Feb 2011
Donate to Me
More
Quote:
Originally Posted by StevePritchard

I've seen this behaviour with batteries before. Not sure if it's due to damage or not, but I've found that a) they sometimes work fine in different phones, and b) are replacement battery seems to fix the problem.

Cheers,

Steve.

I tried replacing the battery with a new one with the same result. Since the battery is too dead to get into fastboot with the key combinations, I wonder if I could use adb and reboot in fastboot and flash factory firmware to get it charging again. The battery was almost dead when I removed it from the phone initially. Could it be possible some type of error was set in the software and reflashing it might solve the problem?
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes