5,599,911 Members 45,986 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Help problem solved for BROM_ERROR : S_DL_GET_DRAM_SETTING_FAIL (5054)

Tip us?
 
sonloy777
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 2
Join Date: Jun 2013
Unhappy [Q] Help problem solved for BROM_ERROR : S_DL_GET_DRAM_SETTING_FAIL (5054)

I'm sorry for same questions. But I have your help to unbrick my devices.

Devices information :
Product Name : MITO
Hardware : MT6577
Model : T720
Build number : GM1502_M17_V1.6
Build date UTC : 20130121-062156
Android v : 4.0.4
Baseband v: GM1502_M17_V1.1, 2013/01/14 16:53
Kernel v : 3.0.13 (gm1225@gm1225) (gcc version 4.4.3 (GCC) ) #1 SMP Mon Jan 21 14:15:59 CST 2013
RAM : 512 - ROM: 4GB


I do flashing with SP_Flash_Tool_v3.1224.01 for this device . But never successfully processed . Though I have used the stock rom I had a previous backup of the other similar device . When running on a flashing red bar reaches 100 % , always an error with the message : BROM_ERROR : S_DL_GET_DRAM_SETTING_FAIL ( 5054 ) .

I have tried many times some existing solutions in this forum . But still there is no way I can get in to flashing on the device . Here are the steps I did in when flashing with tools :

1 . Turning off and unplugging devices battery (I also have tried to flash with battery but failed)
2 . Plug in USB cable to the devices ( but not to the PC )
3 . Installing the USB VCOM driver for MTK MTK6577
4 . Running SP Flash Tool and enter Scatter File
5 . Click the "Download" button on the SP Flash Tools
6 . Plug in the USB cable from the devices to the computer while pressing the volume up button .
7 . Looking into the computer screen flashing process is happening .


Initially there is a process with a red bar marks . Device driver is detected as well ( seen in the device manager ) . When the bar reaches 100 % in the red , the device is detected by the DA USB VCOM port ( COM 28 ) . But immediately displays an error message BROM_ERROR : S_DL_GET_DRAM_SETTING_FAIL ( 5054 ) and the process of flashing the device failed .

I 've tried to uninstall the drivers from USBDeview tools and also through the Device Manager and then install the driver again . But the result remains the same . Port MTK Preloader was never detected . I tried flashing again with a different usb port results also failed . I use the Windows 8 operating system for flashing . I tried with the Windows XP system too but still failed .

Is there a way to revive my device ? . I really - really need your help .

Thank you for the solution that is given .
Attached Thumbnails
Click image for larger version

Name:	asdf.png
Views:	1898
Size:	29.2 KB
ID:	2468153   Click image for larger version

Name:	Untitled.png
Views:	1599
Size:	49.2 KB
ID:	2468154  
 
patenpisan
Old
#2  
Junior Member
Thanks Meter 0
Posts: 4
Join Date: Oct 2013
That error because flashing wrong preloader and dsp_bl. You can use preloader and dsp_bl from mito A300. I Successfull solve that error and unbrick my Mito T720.
 
droidinterest
Old
#3  
droidinterest's Avatar
Member
Thanks Meter 20
Posts: 73
Join Date: Sep 2012
Location: Bogor
on windows 8 try to disable driver signature verification,and install again your mtk driver
 
sonloy777
Old
#4  
Junior Member - OP
Thanks Meter 0
Posts: 2
Join Date: Jun 2013
Question [HELP] Not fully solved

Quote:
Originally Posted by patenpisan View Post
That error because flashing wrong preloader and dsp_bl. You can use preloader and dsp_bl from mito A300. I Successfull solve that error and unbrick my Mito T720.
Thank's, I Successfull solve that error and unbrick this device. but i have a new problem. Invalid IMEI and no SIM card detected, and Unknown Baseband. Can u help me to fix it again ?,
 
patenpisan
Old
#5  
Junior Member
Thanks Meter 0
Posts: 4
Join Date: Oct 2013
Quote:
Originally Posted by sonloy777 View Post
Thank's, I Successfull solve that error and unbrick this device. but i have a new problem. Invalid IMEI and no SIM card detected, and Unknown Baseband. Can u help me to fix it again ?,
You need correct modem.img from same baseband
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes