5,596,637 Members 43,435 Now Online
XDA Developers Android and Mobile Development Forum

Wifi won't connect to the Internet

Tip us?
 
Freakadude
Old
#1  
Member - OP
Thanks Meter 11
Posts: 48
Join Date: May 2013
Default Wifi won't connect to the Internet

So i have ViperOne 4.1.0 running with Elemental X 10.8 kernel for over a week now. Everything was working fine up until yesterday when suddenly my phone cannot get an external IP address on my Wifi at home anymore. It connects fine to the Wifi itself however it cannot get any internet connection.

I have reset my router, modem, phone and nothing has worked. Other devices in my home which connect to the same wifi get internet connection just fine only my HTC One does not. Mobile data connection works fine btw.

Whats really puzzling to me is that really i have changed nothing on my phone in the last couple of days and not all of a sudden its simply not working so i'm grasping at straws here...

Anybody experiences similar issues or have any ideas what else i could still try to fix this?

Thanks
 
Freakadude
Old
#2  
Member - OP
Thanks Meter 11
Posts: 48
Join Date: May 2013
Well it turns out that changing the Wifi channel on the router from auto (was actually 9) to 11 in my case solved the problem. Weird ****...

Sent from my HTC One using xda app-developers app
The Following User Says Thank You to Freakadude For This Useful Post: [ Click to Expand ]
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes