Default [Q] Building Android application for multiple versions

Please help answering this question...
Can you please share your experiences mitigating issues revolving around supporting multiple generations of AOSP, specifically 2.3 and current JB. What are some of the obstacles you have faced, and how have you overcome them in respect to building for multiple generations of the OS.