Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Wifi only access to google.com

OP dkloos

5th January 2014, 03:38 PM   |  #1  
OP Junior Member
Thanks Meter: 2
 
8 posts
Join Date:Joined: Oct 2012
Hi there,

I'll explain what's wrong here, I have a Samsung S3 i9300 with Android 4.3.1 (SlimBean) and everything works fine. Only when I turn on WiFi (tried several), my internet acces is limited to the google site, and some apps like Facebook and Whatsapp. But when I try to navigate to other websites, I recieve a -Not found- error.

So it seems like technically everything is ok (otherwise I also couldn't open google in my browser). Other devices connected to the same network do not have this issue. I tried to change DNS settings (e.g. 8.8.8.8), but this is not possible in 4.3.1 as far as I can see.

Any suggestions are welcome!
5th January 2014, 03:58 PM   |  #2  
Junior Member
Flag Mumbai
Thanks Meter: 3
 
12 posts
Join Date:Joined: Jan 2014
More
Quote:
Originally Posted by dkloos

Hi there,

I'll explain what's wrong here, I have a Samsung S3 i9300 with Android 4.3.1 (SlimBean) and everything works fine. Only when I turn on WiFi (tried several), my internet acces is limited to the google site, and some apps like Facebook and Whatsapp. But when I try to navigate to other websites, I recieve a -Not found- error.

So it seems like technically everything is ok (otherwise I also couldn't open google in my browser). Other devices connected to the same network do not have this issue. I tried to change DNS settings (e.g. 8.8.8.8), but this is not possible in 4.3.1 as far as I can see.

Any suggestions are welcome!

Does it happen on a particular WiFi network or any WiFi?

Is your WiFi hidden?
You can try making Android forget this network & again manually setting it up.

You can also check for any App that may be restricting WiFi traffic

EDIT:
You can change WiFi network settings even in 4.4.2 KitKat

Long Press your Wifi -> Modify Network -> Check 'Show Advanced Options' -> Change IP Settings to 'Static'
Now all settings incl DNS will be visible & you can change them.
Last edited by lokeshi007; 5th January 2014 at 04:09 PM.
The Following User Says Thank You to lokeshi007 For This Useful Post: [ View ]
5th January 2014, 04:05 PM   |  #3  
OP Junior Member
Thanks Meter: 2
 
8 posts
Join Date:Joined: Oct 2012
I tested several networks and they're not hidden.

I use DroidWall, but uninstalling this does not have an effect unfortunately. Also forgetting and reconnecting does not help.

[EDIT]
Thanks for the tip, however this also does not give me access to the rest of the world wide web..
Last edited by dkloos; 5th January 2014 at 04:22 PM.
5th January 2014, 04:32 PM   |  #4  
Junior Member
Flag Mumbai
Thanks Meter: 3
 
12 posts
Join Date:Joined: Jan 2014
More
Quote:
Originally Posted by dkloos

I tested several networks and they're not hidden.

I use DroidWall, but uninstalling this does not have an effect unfortunately. Also forgetting and reconnecting does not help.

[EDIT]
Thanks for the tip, however this also does not give me access to the rest of the world wide web..

Did try using some software such as Wifi Connection Fixer?

Also did you try using different browsers on your phone?

I was having such an issue with ebay.in on the stock browser my i9300. But the same thing loaded perfectly with Chrome.
Clearing the Data & Cache of the stock browser helped later on.
5th January 2014, 04:38 PM   |  #5  
OP Junior Member
Thanks Meter: 2
 
8 posts
Join Date:Joined: Oct 2012
I will try the Wifi Fixer, thanks!

I tried two different browsers without luck, and it is a problem beyond the browser imo, because the Play Store also can not download apps when connected to WiFi. I can search for apps, but when I want to download them, it gives me a -no connection, retry-..
5th January 2014, 04:43 PM   |  #6  
Junior Member
Flag Mumbai
Thanks Meter: 3
 
12 posts
Join Date:Joined: Jan 2014
More
Quote:
Originally Posted by dkloos

I will try the Wifi Fixer, thanks!

I tried two different browsers without luck, and it is a problem beyond the browser imo, because the Play Store also can not download apps when connected to WiFi. I can search for apps, but when I want to download them, it gives me a -no connection, retry-..

If nothing works, I guess you might have to reflash your ROM after clearing the whole data & cache..

IMO, CM11 M2 (Android 4.4.2) is quite good, just flashed it on my S3..
5th January 2014, 05:24 PM   |  #7  
OP Junior Member
Thanks Meter: 2
 
8 posts
Join Date:Joined: Oct 2012
Well, I now changed the DNS settings to the google DNS server (8.8.8.8 and 8.8.4.4) and rebooted the phone and this did the trick.

I don't really understand it, but I am glad I can use my phone without wiping it completely again!
5th January 2014, 06:12 PM   |  #8  
Junior Member
Flag Mumbai
Thanks Meter: 3
 
12 posts
Join Date:Joined: Jan 2014
More
Smile
Quote:
Originally Posted by dkloos

Well, I now changed the DNS settings to the google DNS server (8.8.8.8 and 8.8.4.4) and rebooted the phone and this did the trick.

I don't really understand it, but I am glad I can use my phone without wiping it completely again!

Great!
Enjoy using your phone once again!

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes