Default boot loop odin Nand Write Start!!

So I've tried a lot of things, was running CMW and having some issues with cm11, so I wanted to go back to stock.

Found this thread:

http://forum.xda-developers.com/show....php?t=2582290

Tried to go through the same process because it seems like we had the same problem, Download mode works but Recovery doesn't.

I keep trying to flash:
philz_touch_6.07.9-i605.tar.md5

<ID:0/003> Odin v.3 engine (ID:3)..
<ID:0/003> File analysis..
<ID:0/003> SetupConnection..
<ID:0/003> Initialzation..
<ID:0/003> Get PIT for mapping..
<ID:0/003> Firmware update start..
<ID:0/003> SingleDownload.
<ID:0/003> recovery.img
<ID:0/003> NAND Write Start!!
<ID:0/003> FAIL!
<ID:0/003>
<ID:0/003> Complete(Write) operation failed.
<OSM> All threads completed. (succeed 0 / failed 1)

I get the Nand Write Start!!

----------------------------------------------------------------------------------

So I tried check "Nand Erase All" and "T Flash"

End up with

<ID:0/003> Odin v.3 engine (ID:3)..
<ID:0/003> File analysis..
<ID:0/003> SetupConnection..
<ID:0/003> Initialzation..
<ID:0/003> Erase...
<ID:0/003>
<ID:0/003> Complete(Write) operation failed.
<OSM> All threads completed. (succeed 0 / failed 1)

It fails but doesn't tell me why. I've tried different USB ports, Different Computers, different cables,

------------------------------------------------------------------------

When I try Odin 1.3 I get

<ID:0/003> Added!!
<ID:0/003> Odin v.3 engine (ID:3)..
<ID:0/003> File analysis..
<ID:0/003> Enter CS for MD5..
<ID:0/003> Check MD5.. Do not unplug the cable..
<ID:0/003> Please wait..
<ID:0/003> Checking MD5 finished Sucessfully..
<ID:0/003> Leave CS..
<ID:0/003> SetupConnection..
<ID:0/003> Initialzation..
<ID:0/003> Get PIT for mapping..
<ID:0/003> Firmware update start..
<ID:0/003> recovery.img
<ID:0/003>
<ID:0/003> Complete(Write) operation failed.
<OSM> All threads completed. (succeed 0 / failed 1)

Again doesn't show me what's failing.

So I'm at a total loss right now, I'm trying to avoid doing a PIT because everyone is talking about how it never works and just breaks phones. I'm not sure what other options I have because I can't get a boot loader on here that works.


Tried flashing:

I605_VRAMC3_RESTORE.tar.md5

and still end up with the same kinda results.

So any idea on what I should try next, still trying to avoid PIT because everyone has made it sound really scary.