5,597,815 Members 37,327 Now Online
XDA Developers Android and Mobile Development Forum

Battery does not charge and not even discharges

Tip us?
 
tushar.mokal
Old
#1  
Member - OP
Thanks Meter 3
Posts: 38
Join Date: Apr 2011
Location: Mumbai
Default Battery does not charge and not even discharges

Hi Friends,

I have an unusual error, From morning my phone is not able to charge.

When the battery got drained till 10%, I removed the battery and charged the phone without booting it and charged till 100% as per the display which stucks till i removed the battery.

Again i booted the device....Now it is showing 53% battery even after one hour, Previously it gets fully drained within 1 - 2 hours.

Even PC is not detecting my phone via USB.....Please help.
Samsung Galaxy S Advance I9070
CM11 by Team Canjica
 
tushar.mokal
Old
#2  
Member - OP
Thanks Meter 3
Posts: 38
Join Date: Apr 2011
Location: Mumbai
Quote:
Originally Posted by tushar.mokal View Post
Hi Friends,

I have an unusual error, From morning my phone is not able to charge.

When the battery got drained till 10%, I removed the battery and charged the phone without booting it and charged till 100% as per the display which stucks till i removed the battery.

Again i booted the device....Now it is showing 53% battery even after one hour, Previously it gets fully drained within 1 - 2 hours.

Even PC is not detecting my phone via USB.....Please help.
Now Battery is reduced by 2% after long time but still not able to charge.
Samsung Galaxy S Advance I9070
CM11 by Team Canjica
 
shut_down
Old
#3  
shut_down's Avatar
Senior Member
Thanks Meter 2756
Posts: 6,382
Join Date: Sep 2010
Location: Belgrade
Quote:
Originally Posted by tushar.mokal View Post
Now Battery is reduced by 2% after long time but still not able to charge.
That sounds like indicator problem. What ROM you use? Try to wipe cache and dalvik cache.

Sent from my GT-I9070 using Tapatalk
 
tushar.mokal
Old
#4  
Member - OP
Thanks Meter 3
Posts: 38
Join Date: Apr 2011
Location: Mumbai
Quote:
Originally Posted by shut_down View Post
That sounds like indicator problem. What ROM you use? Try to wipe cache and dalvik cache.

Sent from my GT-I9070 using Tapatalk
HarshJelly 4.01
Kernel Cocore 8.2
Samsung Galaxy S Advance I9070
CM11 by Team Canjica
 
tushar.mokal
Old
#5  
Member - OP
Thanks Meter 3
Posts: 38
Join Date: Apr 2011
Location: Mumbai
Quote:
Originally Posted by shut_down View Post
That sounds like indicator problem. What ROM you use? Try to wipe cache and dalvik cache.

Sent from my GT-I9070 using Tapatalk
I have done Wipe cache & Dalvik Cache but gets screen gets stuck on boot animation So again I installed HJ v1.00 & then update with HJ v4.01 but the situation doesn't changed.

Now I am facing below problems:-
1) Not able to Charge mobile.
2) Not able to connect Phone with PC through USB (USB Device not recognized).
3) I need to remove Battery and charge the Phone without booting it.
4) Battery full charged Icon does not go even after Charger connection is removed.
5) While connecting Charger, Screen flicker's sometime.

Please help.
Samsung Galaxy S Advance I9070
CM11 by Team Canjica
 
shut_down
Old
#6  
shut_down's Avatar
Senior Member
Thanks Meter 2756
Posts: 6,382
Join Date: Sep 2010
Location: Belgrade
Quote:
Originally Posted by tushar.mokal View Post
I have done Wipe cache & Dalvik Cache but gets screen gets stuck on boot animation So again I installed HJ v1.00 & then update with HJ v4.01 but the situation doesn't changed.

Now I am facing below problems:-
1) Not able to Charge mobile.
2) Not able to connect Phone with PC through USB (USB Device not recognized).
3) I need to remove Battery and charge the Phone without booting it.
4) Battery full charged Icon does not go even after Charger connection is removed.
5) While connecting Charger, Screen flicker's sometime.

Please help.
Maybe some hardware problem, I do not get any idea what cause it...
 
tushar.mokal
Old
#7  
Member - OP
Thanks Meter 3
Posts: 38
Join Date: Apr 2011
Location: Mumbai
Thanks for the reply Shut_ down.

Everything starts happening when I removed my sim and put in the another Android mobile and then again in my Mobile.

I recd one GPRS setting message from Vodafone but I ignored the same.

Is the cause root.

Now whenever I Power off my phone it starts automatically within 15-20 seconds.

Sent from my GT-I9070 using Tapatalk
Samsung Galaxy S Advance I9070
CM11 by Team Canjica
 
shut_down
Old
#8  
shut_down's Avatar
Senior Member
Thanks Meter 2756
Posts: 6,382
Join Date: Sep 2010
Location: Belgrade
Quote:
Originally Posted by tushar.mokal View Post
Thanks for the reply Shut_ down.

Everything starts happening when I removed my sim and put in the another Android mobile and then again in my Mobile.

I recd one GPRS setting message from Vodafone but I ignored the same.

Is the cause root.

Now whenever I Power off my phone it starts automatically within 15-20 seconds.

Sent from my GT-I9070 using Tapatalk
Hmmm, maybe your micro usb connector on phone is faulty. When you connect cable with PC it will act like that...
 
tushar.mokal
Old
#9  
Member - OP
Thanks Meter 3
Posts: 38
Join Date: Apr 2011
Location: Mumbai
What is the solution for it..... Just now I have changed my battery.

Battery size was increased / Swollen type.

Sent from my GT-I9070 using Tapatalk
Samsung Galaxy S Advance I9070
CM11 by Team Canjica

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


XDA PORTAL POSTS

Polish Your Custom Themes with Theme Debugger

Creating a custom Android theme from scratch can be quite the laborious task. In addition to … more

Clean Up Your Logcat Code with Lib Cleaner

Some of you may think that writing code is the hardest part of development. It’s not, as the … more

Tweak Your Xperia Device’s Camera App Yourself

We’ve come to expect nearly perfect cameraperformancein our modern day … more