Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

HW mic issue - need to record mono

OP ldmelo

5th January 2014, 03:25 AM   |  #1  
OP Member
Thanks Meter: 9
 
96 posts
Join Date:Joined: Mar 2007
This is an unusual request. Is there a way to make the camera app record video with mono audio?

I have an international i9505, rooted, but my s4 seems to be affected with some kind of mic defect that makes one of the audio channels present a lot of pops and cracking sounds. This seems to be a hardware issue that affects some s4,specially the first ones sold in Europe.

The best workaround I found so far is to record stereo and discard the audio from the defective channel afterwards, in a painful process that includes transferring the files to a pc for processing...

I found some 3rd party camera apps that have this option (mono audio ), like "camera jb+" and "snap camera hdr". I bought both, but they generate 15fps files that are much worse than the 30fps files from the s4 default camera app.

So.. What I am wondering is if I could somehow change the way the camera app records audio (maybe changing some xml,... I don't know).

Or... Maybe someone could point me some nice 3rd party app that could solve my issue.
Last edited by ldmelo; 5th January 2014 at 03:45 AM.
5th January 2014, 05:14 AM   |  #2  
smep's Avatar
Senior Member
Thanks Meter: 36
 
219 posts
Join Date:Joined: Jul 2013
Why not Update the whole firmware ? You may solve this issue

Sent from my PS3
5th January 2014, 08:58 PM   |  #3  
OP Member
Thanks Meter: 9
 
96 posts
Join Date:Joined: Mar 2007
Quote:
Originally Posted by smep

Why not Update the whole firmware ? You may solve this issue

Sent from my PS3

I have the latest stock firmware. Android 4.3, rom MKE.
6th January 2014, 08:45 AM   |  #4  
smep's Avatar
Senior Member
Thanks Meter: 36
 
219 posts
Join Date:Joined: Jul 2013
You may have to check the mic connector .... maybe you drop the phone and the connector got loose

Sent from dish washer
Last edited by smep; 6th January 2014 at 08:48 AM.
6th January 2014, 10:25 PM   |  #5  
OP Member
Thanks Meter: 9
 
96 posts
Join Date:Joined: Mar 2007
I won't open the phone for that. I think it would give me more problems than benefits.

Besides, the issue is shared by a lot of people and seems to be a hw factory defect. I gave up a long time ago trying to fix it.

See here:

http://forum.xda-developers.com/show....php?t=2317900

What I want now is a good workaround. Maybe a camera mod that allows me to record mono...





Sent from my GT-I9505 using xda app-developers app
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes