5,597,007 Members 47,734 Now Online
XDA Developers Android and Mobile Development Forum

Charging issue

Tip us?
 
sharonbw
Old
#1  
sharonbw's Avatar
Senior Member - OP
Thanks Meter 124
Posts: 644
Join Date: Sep 2012
Default Charging issue

My phone has begun draining rapidly. When it is plugged in, while booted up but screen off, it gets very hot and doesn't charge. If I turn it off, it will charge. Could this be Rom or kernel related or is something wrong with my phone or battery?

Sent from my GT-p511x
 
4-2ndtwin
Old
(Last edited by 4-2ndtwin; 6th January 2014 at 12:10 AM.)
#2  
4-2ndtwin's Avatar
Recognized Contributor
Thanks Meter 2404
Posts: 3,004
Join Date: Dec 2010
Location: Arkansas

 
DONATE TO ME
Best way to tell would of course be to flash back to Stock firmware and see how it does.
That is what i would do. And i would flash the Android 4.1.2 Stock i777ucMD8.
U could also get Root after Stock and install the BetterBatteryStats app to help ya see what is using ur battery.

Sent from my SAMSUNG-SGH-I747 using Tapatalk




The Following 4 Users Say Thank You to 4-2ndtwin For This Useful Post: [ Click to Expand ]
 
sharonbw
Old
#3  
sharonbw's Avatar
Senior Member - OP
Thanks Meter 124
Posts: 644
Join Date: Sep 2012
I tried to flash cooked but it wouldn't boot. I know it was a good download because I'd flashed it before. It also won't boot AOCP 7. In addition two nandroid backups failed to restore. Strangely, by flashing partitions separately I was able to get CM11 to restore even though it said system failed. I'm confused and frustrated right now. I'm going to flash RenderBroken's nightly tomorrow and see if I still have problems.

Btw, bbs hasn't been working for me either. It's been giving me weird numbers that don't make sense like 19 hours since boot when it's been around 2.

I wonder if it's just time for me to get an S4...

Sent from my SGH-I777 using xda app-developers app
 
pepe100
Old
#4  
Senior Member
Thanks Meter 74
Posts: 102
Join Date: Sep 2013
Quote:
Originally Posted by sharonbw View Post
I tried to flash cooked but it wouldn't boot. I know it was a good download because I'd flashed it before. It also won't boot AOCP 7. In addition two nandroid backups failed to restore. Strangely, by flashing partitions separately I was able to get CM11 to restore even though it said system failed. I'm confused and frustrated right now. I'm going to flash RenderBroken's nightly tomorrow and see if I still have problems.

Btw, bbs hasn't been working for me either. It's been giving me weird numbers that don't make sense like 19 hours since boot when it's been around 2.

I wonder if it's just time for me to get an S4...

Sent from my SGH-I777 using xda app-developers app
Do not give up the s2 i777 is a great phone try to solve problems and be happy with your device.

Sent from my SGH-I777 using xda app-developers app
The Following User Says Thank You to pepe100 For This Useful Post: [ Click to Expand ]
 
SighIsAnonymous
Old
#5  
Junior Member
Thanks Meter 4
Posts: 16
Join Date: Dec 2013
Location: Oklahoma City
What ROM were you using before? this happened to me after coming back from Kit-Kat. Id recommend flashing a CM-10.2 nightly. It could just be the battery. Maybe even the charger port! Id flash a new ROM first though.
 
sharonbw
Old
#6  
sharonbw's Avatar
Senior Member - OP
Thanks Meter 124
Posts: 644
Join Date: Sep 2012
I am on CM11. I wiped my phone but ended up just reinstalling the nandroid I had made so am still on CM11. Interestingly, the problem is not happening today. I believe it may have been a rogue app or process. I'm hoping the phone/battery is still good because I'm broke! Lol

Sent from my GT-p511x
The Following User Says Thank You to sharonbw For This Useful Post: [ Click to Expand ]
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes