Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,805,233 Members 51,153 Now Online
XDA Developers Android and Mobile Development Forum

Android 4.4 - Wi-Fi is intermittent, buffering, dropping connections on Nexus devices

Tip us?
 
Hyflex
Old
(Last edited by Hyflex; 6th January 2014 at 07:21 AM.)
#1  
Hyflex's Avatar
Senior Member - OP
Thanks Meter 42
Posts: 392
Join Date: Jan 2011
Location: London
Default Android 4.4 - Wi-Fi is intermittent, buffering, dropping connections on Nexus devices

Hey,

I've recently upgraded my Nexus 4, Nexus 7 and Nexus 10 all to Android 4.4 and as soon as I upgraded my Wi-Fi has been awful.

The Wi-Fi is incredibly unstable, steaming media has major buffering / intermittency issues, messages sent over instant messaging apps are sometimes instant and sometimes take 30+ seconds to send.

Skype is the most telling of the issues as it randomly loses connection and my notifications literally never come through...

Router Wi-Fi Settings:


I've tried Channels, 1, 2, 4, 6, 8, 10 and 11

I've also tried adding
Code:
gDataInactivityTimeout=200
to the WCNSS_qcom_cfg.ini file as found: http://forum.xda-developers.com/show....php?t=2300873

Wi-Fi is Always On, Wi-Fi Frequency is Auto or 2.4, Wi-Fi Optimization is Off.

The wireless / wifi works fine on other tablets, laptops and wireless devices just my nexus devices on 4.4

Anyone got any ideas?
if (Signature = TRUE) {
.. if (Device = "Google Nexus 4") {
.... ROM = Stock (Android 4.4) with Xposed;
.... KERNEL = Stock;
.. }
.. if (Device = "Google Nexus 10") {
.... ROM = Stock (Android 4.4) with Xposed;
.... KERNEL = Stock;
.. }
} else {
.. Retired Devices == HTC Desire Z, ASUS Eee Pad Transformer Prime, Microsoft Surface RT;
}
}
 
Hyflex
Old
#2  
Hyflex's Avatar
Senior Member - OP
Thanks Meter 42
Posts: 392
Join Date: Jan 2011
Location: London
I think this logcat has everything "confidential" replaced however if anyone does find something please tell me, I've replaced my email with xxxx.xxxx and my usernames with xxxx

Logcat: http://pastebin.com/raw.php?i=LrvQEJLB

MTU Value is at Auto (1492, which my ISP recommends) although I've tried alternative numbers but still no luck.
if (Signature = TRUE) {
.. if (Device = "Google Nexus 4") {
.... ROM = Stock (Android 4.4) with Xposed;
.... KERNEL = Stock;
.. }
.. if (Device = "Google Nexus 10") {
.... ROM = Stock (Android 4.4) with Xposed;
.... KERNEL = Stock;
.. }
} else {
.. Retired Devices == HTC Desire Z, ASUS Eee Pad Transformer Prime, Microsoft Surface RT;
}
}
 
CtrlAltDelIrl
Old
#3  
CtrlAltDelIrl's Avatar
Senior Member
Thanks Meter 834
Posts: 1,387
Join Date: Mar 2012
Try the WiFi Keep Alive app from the Playstore and select Always On.

I know you already have this setting picked but I had the same issue and this solved it for me.

Good luck.
My PM is not for your personal help or support All support requests will be ignored.
 
Hyflex
Old
#4  
Hyflex's Avatar
Senior Member - OP
Thanks Meter 42
Posts: 392
Join Date: Jan 2011
Location: London
Quote:
Originally Posted by CtrlAltDelIrl View Post
Try the WiFi Keep Alive app from the Playstore and select Always On.

I know you already have this setting picked but I had the same issue and this solved it for me.

Good luck.
I just installed three different versions of Wi-Fi Keep Alive, the first one has 3 normal options then like 5 workarounds.
I'm trying the normal mode at the moment, so far so good it hasn't disconnected me YET
if (Signature = TRUE) {
.. if (Device = "Google Nexus 4") {
.... ROM = Stock (Android 4.4) with Xposed;
.... KERNEL = Stock;
.. }
.. if (Device = "Google Nexus 10") {
.... ROM = Stock (Android 4.4) with Xposed;
.... KERNEL = Stock;
.. }
} else {
.. Retired Devices == HTC Desire Z, ASUS Eee Pad Transformer Prime, Microsoft Surface RT;
}
}
The Following User Says Thank You to Hyflex For This Useful Post: [ Click to Expand ]
 
CtrlAltDelIrl
Old
#5  
CtrlAltDelIrl's Avatar
Senior Member
Thanks Meter 834
Posts: 1,387
Join Date: Mar 2012
I picked always on + first workaround.

It worked great and haven't changed it since. That's 3 weeks now and it hasn't dropped out once

Hope that helped you.
My PM is not for your personal help or support All support requests will be ignored.
 
Hyflex
Old
#6  
Hyflex's Avatar
Senior Member - OP
Thanks Meter 42
Posts: 392
Join Date: Jan 2011
Location: London
Quote:
Originally Posted by CtrlAltDelIrl View Post
I picked always on + first workaround.

It worked great and haven't changed it since. That's 3 weeks now and it hasn't dropped out once

Hope that helped you.
Thanks, I'll keep trying as on my Nexus 4 it is playing up with just always on, I'm trying the workarounds.

Anyone else got any suggestions?
if (Signature = TRUE) {
.. if (Device = "Google Nexus 4") {
.... ROM = Stock (Android 4.4) with Xposed;
.... KERNEL = Stock;
.. }
.. if (Device = "Google Nexus 10") {
.... ROM = Stock (Android 4.4) with Xposed;
.... KERNEL = Stock;
.. }
} else {
.. Retired Devices == HTC Desire Z, ASUS Eee Pad Transformer Prime, Microsoft Surface RT;
}
}
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


CyanogenMod 11 M10 Available for Supported Devices

Summer vacation isover for most students out there, and it’s the time to get back to … more

XDA Forums Added for the First Batch of Android One Devices!

Just yesterday, we talked about the highly anticipated launch of the first batch … more

XDA Xposed Tuesday: DonkeyGuard, Don’t Be a Donkey, Control Your Device – XDA Developer TV

Some applications ask for the world … more

Use Facebook Pictures as a LWP with Facebook View

One of the best things that Android has always offeredits users is the ability to tailor … more