Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,737,406 Members 42,024 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Boot loop, can boot to twrp/fastboot, but cant flash any roms.

Tip us?
 
tebuddy
Old
#1  
Member - OP
Thanks Meter 13
Posts: 96
Join Date: Nov 2011
Default [Q] Boot loop, can boot to twrp/fastboot, but cant flash any roms.

Okay so heres the deal. Bought a new evita from a dealer. Dont remember/have what the stock software was, but it was booting with an att rom and all the bloatware. I downloaded the all in one eztoolkit and unlocked the bootloader successfully. Heres my problem, I can get into fastboot and twrp, but all of my flashes fail regardless of what rom I flash. I tried cm 10.2, 10.4, and 11 beta and they all failed. Then I tried to revert using both att ruus I could find, including the 2.20 and 3.18 updates directly from att. Both of them reboot to the ruu loader and appear to be working, but fail citing the incorrect software version. I assume its because I manually changed the recovery and flashed boot.img files from each of the roms I tried to flash, but I am not certain. Heres is the getvar information:

Code:
Select Code
(bootloader) version: 0.5
(bootloader) version-bootloader: 1.14.0002
(bootloader) version-baseband: 0.19as.32.09.11_
(bootloader) version-cpld: None
(bootloader) version-microp: None
(bootloader) version-main: 2.20.502.7
(bootloader) version-misc: PVT SHIP S-ON
(bootloader) serialno: HT24DW304126
(bootloader) imei: 359691042468010
(bootloader) product: evita
(bootloader) platform: HBOOT-8960
(bootloader) modelid: PJ8310000
(bootloader) cidnum: 11111111
(bootloader) battery-status: good
(bootloader) battery-voltage: 3897mV
(bootloader) partition-layout: Generic
(bootloader) security: on
(bootloader) build-mode: SHIP
(bootloader) boot-mode: FASTBOOT
(bootloader) commitno-bootloader: 1a7fdca3
(bootloader) hbootpreupdate: 11
(bootloader) gencheckpt: 0
all: Done!
Can this be solved by flashing the correct rom, and if so can you direct me to it? Otherwise, how can I fix this?

Thank you.
 
tebuddy
Old
(Last edited by tebuddy; 7th January 2014 at 07:31 AM.)
#2  
Member - OP
Thanks Meter 13
Posts: 96
Join Date: Nov 2011
edit: flashed cm 10.0.0 and related gapps after manually flashing the boot.img and I got it to boot.

Going to try to s-off so I can be done with all this garbage.

edit: Got it booting, got s-off. Still on 10.0.0 with root and s-off. Not sure where to go from here unless anyone can give me further direction. I'd prefer to have the latest cyanogen etc, but I am ok with this if I cant go any further.

Thanks all !
 
timmaaa
Old
(Last edited by timmaaa; 7th January 2014 at 08:08 AM.)
#3  
timmaaa's Avatar
Recognized Contributor
Thanks Meter 5318
Posts: 11,485
Join Date: Jun 2011
Location: Melbourne

 
DONATE TO ME
Where are you downloading your ROMs? You mentioned earlier that you flashed cm10.4 but there is no such ROM for this device. You need to be careful about where you get your ROMs, flashing a ROM that isn't intended for this device can easily result in a brick.

Your ROM flashes were failing because your firmware is too old, it does state pretty clearly in the install instructions on the cm threads that you need to update your firmware via the 3.18 RUU. So you need to download the 3.18 RUU and run that which will update your firmware. Here's a very useful thread which details how to run an RUU.

After you've done that you'll need to flash TWRP again. If you want to flash the latest cm, which is cm11, you need to install the modified version of TWRP 2.6.3.0 recovery which can be found in our Original Android Development section. Download the modified version of TWRP 2.6.3.0 from here. Put the file in your fastboot folder. Connect phone in fastboot mode, open command prompt from within fastboot folder, issue the following commands:

Code:
Select Code
fastboot flash recovery "filename.img"
(the exact filename, minus the talking marks)

Code:
Select Code
fastboot erase cache
Code:
Select Code
fastboot reboot-bootloader
Now you can enter TWRP and flash your ROM + gapps. Because you're new here I'd suggest you click the Everything Evita link in my signature and bookmark it, it contains links to basically everything for our phone. You should also click the other links in my signature and read those threads, you'll find them very helpful. Here's a few important links for you too:

One XL Main Page

http://forum.xda-developers.com/forumdisplay.php?f=1538

One XL Q&A

http://forum.xda-developers.com/forumdisplay.php?f=1572

One XL Android Development

http://forum.xda-developers.com/forumdisplay.php?f=1541

One XL Original Android Development

http://forum.xda-developers.com/forumdisplay.php?f=1726

Make sure you only ever download ROMs from the development sections I've linked there, many people make the mistake of wandering into the HTC One X forum and flashing those ROMs, many of those people bricked their phone. That might seem confusing but you don't have the HTC One X (Endeavoru), you have the HTC One XL / at&t One X (Evita). If you have any further questions just ask either here or in my q&a thread (link in my signature).

Sent from my Evita
HTC Evita | CandyKat | Torched KK
S-off | 2.18 | TWRP 2.7.1.0
Do not PM me asking for assistance, that's what my Q&A thread is for!
The Following User Says Thank You to timmaaa For This Useful Post: [ Click to Expand ]
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes