5,604,050 Members 47,765 Now Online
XDA Developers Android and Mobile Development Forum

[Q] i9000 battery problem, charging port or hardware problem?

Tip us?
 
easyridergirl
Old
#1  
Junior Member - OP
Thanks Meter 1
Posts: 14
Join Date: Sep 2009
Location: Jelgava
Battery Full [Q] i9000 battery problem, charging port or hardware problem?

Hello. Recently i bought SGS and didnt know of problem it has. It ran stock eclair. Once i plugged charger it started to chage but when i unplugged it showed i charge it anyway. I reset default settings but then phone showed that usb is plugged in although it wasnt. But the most annoying thing that i cannot turn it on if charger or usb not plugged in. After it shows start screen with samsung galaxy logo i can unplug it. If i do not plug charger in, then it start showing circle then grey battery and then restarts that same. I upgraded to gingerbread stock but booting problem still hapens each time. My husband tried to look inside the phone, in the charging port there were signs of liquid but all other parts of motherboard were clean. Dont know what to do. Phone works fine when i use it, no other complains.
 
xsenman
Old
#2  
xsenman's Avatar
Recognized Contributor
Thanks Meter 2139
Posts: 3,920
Join Date: Apr 2012
Location: Philippines
Quote:
Originally Posted by easyridergirl View Post
Dont know what to do. Phone works fine when i use it, no other complains.
try cleaning the USB port as mentioned here and also the image at the bottom, for a guide on how to identify where the problem may be to resolve it.

 
easyridergirl
Old
#3  
Junior Member - OP
Thanks Meter 1
Posts: 14
Join Date: Sep 2009
Location: Jelgava
My husband cleaned the usb port, and i updated software. It is charging normally and usb recognizes it, but with a little delay, and also chen i unplug charger, phone detects it but with delay. But not turning on still present. it looks like in other posts battery bootloop. show little circle, then grey battery wih same circle and again. it tries to start even if i turn phone off. I turn it off, after 10 secs it starts to show that circle and grey battery.
 
JFK1997
Old
#4  
Junior Member
Thanks Meter 7
Posts: 28
Join Date: Jan 2014
Quote:
Originally Posted by easyridergirl View Post
My husband cleaned the usb port, and i updated software. It is charging normally and usb recognizes it, but with a little delay, and also chen i unplug charger, phone detects it but with delay. But not turning on still present. it looks like in other posts battery bootloop. show little circle, then grey battery wih same circle and again. it tries to start even if i turn phone off. I turn it off, after 10 secs it starts to show that circle and grey battery.
I think those are hardware related problems. The problem when turned off could be that the phone knows that its getting charged not only through the voltage of the charger but also through a shortened (to mass?) pin. Maybe this pin is always shorted because of the liquid etc. you could try to clean it again or buy and change the usb port
 
c-droid
Old
#5  
Member
Thanks Meter 9
Posts: 69
Join Date: Dec 2013
Probably the phone have a history o drowning/soaking from water or some kind of liquid. If you could dismantle all the parts, but be sure you can assemble them again (try to search Youtube, I think there's a lot of guides on how to do it). Clean all parts with anti-static compress air in can, I think you can buy them from electronic shops. Give special cleaning on the USB port and buttons contacts. You can also blow-dry it with hair dryer.

Hope this helps solve your problem...
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes