Post Reply

[Q] Cubot A890/M6589 Bricked?

OP agentnerdo

7th January 2014, 09:44 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Jan 2014
Hey!

So I finally figured how to update the phone, following the steps on the site; http://www.needrom.com/mobile/cubot-m6589/

I used the 1st file on there, labeled just "CUBOT M6589" (I figured, on top of the list, must be most recent)

I did the update and it showed me an error, and after wards the phone would not turn on. If I plug it in, the computer does recognize something is installed.

I tried flashing it with an older version, and I did get the screen to "turn on", but nothing shows on it. I have also tried flashing it with the suggestion given on "http://forum.xda-developers.com/showthread.php?t=2263122", but it has gone back to not responding to anything (other than connecting to my computer).

The other thread did have a link to another users backup..(which I am downloading, please see the link up, as the backup is linked on it), but I was hoping there was another way? Could I flash it back to working? Reason I prefer to flash it, is because the only instructions I could find to use a backup where in Italian...so I rather stay away from unchartered waters. Unless someone has great English instructions!

Or is the phone a total loss now?
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Questions and Answers by ThreadRank