Post Reply

[Q] Phone freezes up and screen stays black when pressing lock button twice quickly

OP ddmanfire

4th January 2014, 02:08 PM   |  #1  
OP Junior Member
Thanks Meter: 1
 
15 posts
Join Date:Joined: Dec 2010
Every time I press the lock button twice quickly when the screen is off it gets locked up. I do this on accident sometimes. Is this always going to be a problem or can it be fixed?
4th January 2014, 02:16 PM   |  #2  
Recognized Contributor
Thanks Meter: 3,039
 
2,484 posts
Join Date:Joined: Sep 2010
Donate to Me
Which button are you referring to? Do you have SGH-I777?
5th January 2014, 01:18 AM   |  #3  
OP Junior Member
Thanks Meter: 1
 
15 posts
Join Date:Joined: Dec 2010
Yes I have the SGH i777 and I am talking about the power button.
5th January 2014, 01:46 AM   |  #4  
Recognized Contributor
Thanks Meter: 3,039
 
2,484 posts
Join Date:Joined: Sep 2010
Donate to Me
Quote:
Originally Posted by ddmanfire

Yes I have the SGH i777 and I am talking about the power button.

That would be abnormal behavior for the power button. When the screen is off, pressing the button once or twice quickly should make no difference. The screen should come on in either case.

What firmware do you have on the phone? Unless the power button is somehow programmed to recognize a double press somewhere in the firmware, then it is possibly a failing button.
The Following 2 Users Say Thank You to creepyncrawly For This Useful Post: [ View ]
7th January 2014, 10:15 PM   |  #5  
OP Junior Member
Thanks Meter: 1
 
15 posts
Join Date:Joined: Dec 2010
Quote:

That would be abnormal behavior for the power button. When the screen is off, pressing the button once or twice quickly should make no difference. The screen should come on in either case.

What firmware do you have on the phone? Unless the power button is somehow programmed to recognize a double press somewhere in the firmware, then it is possibly a failing button.

Thank you for helping me. I am running the stable build of Cyanogenmod 10.1 (4.2.2) directly from their website. However, I do not quite believe that my power button is failing. It works fine when i click it once. Is there a way to know if its just a software problem vs a hardware problem? Thanks
7th January 2014, 10:21 PM   |  #6  
Recognized Contributor
Thanks Meter: 3,039
 
2,484 posts
Join Date:Joined: Sep 2010
Donate to Me
Quote:
Originally Posted by ddmanfire

Thank you for helping me. I am running the stable build of Cyanogenmod 10.1 (4.2.2) directly from their website. However, I do not quite believe that my power button is failing. It works fine when i click it once. Is there a way to know if its just a software problem vs a hardware problem? Thanks

Yes, of course. Just flash back to stock and see if the problem persists. I would suggest you try 4.1.2 UCMD8, but it really doesn't matter which version. If the problem goes away, then the issue is in firmware. You should be able to make a nandroid backup of your current configuration, and restore it after you finish the test. (I assume you would understand the necessary steps.)
The Following 3 Users Say Thank You to creepyncrawly For This Useful Post: [ View ]
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes