Unhappy [Q] ASUS Memo Pad FHD 10 - bricked because of "unknown partition type"?

Hi @all!

I just 'tried' to root my ASUS Memopad FHD 10 16GB (WW-version).
I post here because I simply think that you guys at XDA are certainly the ones who know the solution, if there is one.

It seems as if the userdata+cache partitions are "destroyed" or something like that.

Having Android 4.3 it was not possible to flash the rooted system-image, so I first wanted to "downgrade fastboot" to the version from the "WW_ME302C-V4.7.3-0-ota-user.zip" firmware and then try again flashing the 4-7-3 firmware. But after flashing fastboot, when I tried wiping all data I got this:

-----------------------
fastboot erase system
fastboot erase cache
fastboot flash fastboot fastboot.img

fastboot -w
erasing 'userdata'...
OKAY [ 15.292s]
formatting 'userdata' partition...
Erase successful, but not automatically formatting.
File system type not supported.
OKAY [ 1.634s]
erasing 'cache'...
OKAY [ 3.607s]
formatting 'cache' partition...
Erase successful, but not automatically formatting.
File system type not supported.
OKAY [ 1.186s]
finished. total time: 21.729s
-----------------------

Since then I cannot format the partitions or userdata. Flashing the firmware 'supposedly' works (console output on PC says 'finished').
But after "fastboot flash update WW_ME302C-V4.7.3-0-ota-user.zip" is done the device restarts immediately, then
1. shows the android figure with opened hatch and a green progress bar
2. figure changes to one having a red triangle inside
3. reboot and then showing the ASUS bootscreen for like 10min.
4. The last step repeats like 4 times, then the android figure with red triangle appears again, then bootscreens again ... (endless loop)

So as you can see I cannot boot into android again. I think the problem lies with the "File system type not supported" but.

When I try to format directly I get:
-----------------------
fastboot format cache
formatting 'cache' partition...
Formatting is not supported for filesystem with type ''.
FAILED ()
finished. total time: 2.303s
-----------------------

Does anyone know how I can fix this and reinstall any firmware?
My ideas were
- format the partitions to ext2/ext3 directly (there should be a way to specify the filesystem, right?)
- flash the userdata/cache partition with someone else's partition content
- use a custom-recovery for the tablet which does this - though I cannot find one anywhere

Thanks XDA! =)

-------------------------------------------------------------------------------------------
SOLVED
-------------------------------------------------------------------------------------------

Thanks to perpe and wakatu the problem has been solved by flashing the original recovery, as specified here:

http://www.android-hilfe.de/asus-mem...ml#post7005266