5,594,805 Members 36,881 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Some simlinks failed, status 7?

Tip us?
 
vinte007
Old
#1  
Junior Member - OP
Thanks Meter 7
Posts: 17
Join Date: Dec 2013
Unhappy [Q] Some simlinks failed, status 7?

Dear xda peeps,

Well, I downloaded CM 10.2 and then put it in my memory card. Then I rebooted into recovery and factory reseted, wiped partition cache and dalvic even. But when I try to flash CM 10.2, it says some simlinks failed, Status 7. And I thought that it was because of a recovery problem thats why I flashed the latest CWM recovery I could get for Nexus One (CWM 5.5) but still the same error. I even flashed TWRP 2.6.0.0 but still the same error.

And also I noticed that the files I push using adb command (adb push recovery.img /sdcard/recovery.img) is in my memory card O_O. I meant like isn't it suppose to be on the phone internal sdcard or something? And the other thing is that I can successfully fastboot all the files I push to sdcard, but I can't use fastboot if I take my memory card out. :S Isn't is suppose to use the internal sdcard?

Stuffs I have tried:
New recoveries,
Factory reset/partition/delvic,
Re downloaded CM 10.2,
unmount system and tried. Annnnddd nothing helped.

So, my real question is, how can I fix this simlink status 7 error? My phone can't boot anymore >.<.
 
demkantor
Old
#2  
demkantor's Avatar
Recognized Contributor
Thanks Meter 2339
Posts: 5,146
Join Date: Nov 2011
Location: mpls
Don't push recovery to SD, us fastboot to flash latest recovery
fastboot flash recovery recovery.img
And make sure you bootloader is partitioned to be large enough, see the black rose thread for me info on how to if need be
Redownload ROM or at least check to make sure md5sum matches as to rule out a bad download


Sent from my Nexus 7 using XDA Premium 4 mobile app
 
sphinxcs898
Old
#3  
sphinxcs898's Avatar
Senior Member
Thanks Meter 56
Posts: 255
Join Date: May 2012
Location: San Jose
One cannot just flash on ICS/JB/KK Roms on the Nexus One.

You are expected to do your due diligence in this area and there are numerous topics abound discussing this exact same topic.

If you try to flash on a ROM which the Nexus One's tiny 512 MB partition doesn't support, then you will get some unpleasant results such as the one you face right now.

The answer in a word is BlackRose - To re-partition your system/cache/data so as to accomodate the JB ROMs.

Follow the steps listed here and do your research before flashing. It can save you a lot of time/stress:

http://forum.xda-developers.com/show....php?t=1804571
HTC One
(Stock)

Google Nexus One(Retired)
ROM: CM10.1 JellyBean 4.2.2 | Paranoid Android 4.2.2 Halo 3.6 | PixelDroid 4.2.2 Carbon
HBOOT: BlackRose 260.10.166
Recovery: 4EXT Recovery Touch v1.0.0.5 RC8
Kernel : 2.6.38.8-evervolv-perdo-jellybean
SD Card : Transcend 16 GB Class 10
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes