5,604,686 Members 37,131 Now Online
XDA Developers Android and Mobile Development Forum

[Q] VPN Connection Problem - KatKiss .029

Tip us?
 
l3py
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 2
Join Date: Sep 2011
Question [Q] VPN Connection Problem - KatKiss .029

First off, I just started using this rom last month, but my old TF101 is like a new tablet. Outstanding work!

I am having an issue connecting to a VPN using the built-in android VPN settings. The VPN server is a simple PPTP VPN running on a Win 7 system, setup through the "Incoming Connections" dialog. Earlier today, the tablet was able to connect to the VPN server no problem; however, it randomly stopped connecting this evening.

When connecting to the VPN, the built-in app starts sitting at "Connecting..." until it changes to "Disconnected". The server is setup correctly and still running as a Win 7 laptop is still able to connect without a hitch using the same wifi connection as the tablet. I also tried clearing cache/Dalvik and fixing permissions to no avail.

The problem might not be specific to this device/rom/android version since a gingerbread phone is also having a similar issue using 3g or wifi. The phone was able to connect earlier in the week but stopped connecting a few days ago. I have pasted the relevant section of the aLogcat log of the tablet below to shed some light on the subject. Can anyone give any input on why this issue might have just started cropping up?

I/mtpd ( 4222): Using protocol pptp
I/mtpd ( 4222): Connecting to ***.***.***.*** port 1723 via wlan0
I/mtpd ( 4222): Connection established (socket = 11)
D/mtpd ( 4222): Sending SCCRQ
D/mtpd ( 4222): Received SCCRP -> Sending OCRQ (local = 20020)
I/mtpd ( 4222): Tunnel established
D/mtpd ( 4222): Received OCRQ (remote = 63187)
I/h mtpd ( 4222): Session established
I/mtpd ( 4222): Creating PPPoX socket
I/mtpd ( 4222): Starting pppd (pppox = 12)
I/mtpd ( 4222): Pppd started (pid = 4223)
I/pppd ( 4223): Using PPPoX (socket = 12)
D/pppd ( 4223): using channel 2
I/pppd ( 4223): Using interface ppp0
I/pppd ( 4223): Connect: ppp0 <-->
D/EthernetService( 752): interfaceAdded: ppp0
D/EthernetService( 752): addInterface: ppp0
D/EthernetService( 752): addInterface: I cannot manage ppp0
D/EthernetService( 752): interfaceLinkStateChanged for ppp0, up = false
 
dr_ether
Old
#2  
dr_ether's Avatar
Junior Member
Thanks Meter 0
Posts: 7
Join Date: Sep 2012
Location: Bochum
Quote:
Originally Posted by l3py View Post
First off, I just started using this rom last month, but my old TF101 is like a new tablet. Outstanding work!

I am having an issue connecting to a VPN using the built-in android VPN settings. The VPN server is a simple PPTP VPN running on a Win 7 system, setup through the "Incoming Connections" dialog. Earlier today, the tablet was able to connect to the VPN server no problem; however, it randomly stopped connecting this evening.

When connecting to the VPN, the built-in app starts sitting at "Connecting..." until it changes to "Disconnected". The server is setup correctly and still running as a Win 7 laptop is still able to connect without a hitch using the same wifi connection as the tablet. I also tried clearing cache/Dalvik and fixing permissions to no avail.

The problem might not be specific to this device/rom/android version since a gingerbread phone is also having a similar issue using 3g or wifi. The phone was able to connect earlier in the week but stopped connecting a few days ago. I have pasted the relevant section of the aLogcat log of the tablet below to shed some light on the subject. Can anyone give any input on why this issue might have just started cropping up?

I/mtpd ( 4222): Using protocol pptp
I/mtpd ( 4222): Connecting to ***.***.***.*** port 1723 via wlan0
I/mtpd ( 4222): Connection established (socket = 11)
D/mtpd ( 4222): Sending SCCRQ
D/mtpd ( 4222): Received SCCRP -> Sending OCRQ (local = 20020)
I/mtpd ( 4222): Tunnel established
D/mtpd ( 4222): Received OCRQ (remote = 63187)
I/h mtpd ( 4222): Session established
I/mtpd ( 4222): Creating PPPoX socket
I/mtpd ( 4222): Starting pppd (pppox = 12)
I/mtpd ( 4222): Pppd started (pid = 4223)
I/pppd ( 4223): Using PPPoX (socket = 12)
D/pppd ( 4223): using channel 2
I/pppd ( 4223): Using interface ppp0
I/pppd ( 4223): Connect: ppp0 <-->
D/EthernetService( 752): interfaceAdded: ppp0
D/EthernetService( 752): addInterface: ppp0
D/EthernetService( 752): addInterface: I cannot manage ppp0
D/EthernetService( 752): interfaceLinkStateChanged for ppp0, up = false

I can confirm I have the same issue. 4.3 rom was fine, 4.4 is not connecting. Definitely not a issue with the vpn or details as I have tested on my phone and pc.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes