Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] disable screen auto wake in android

OP zlange

8th January 2014, 07:46 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
4 posts
Join Date:Joined: Apr 2011
I have a specific problem that has persisted through multiple android devices, through all ROMs and builds.

Currently I am on a Verizon galaxy nexus with cyanogen 10.1 (background in case it's more relevant than I believe).

When a timer or alarm goes off on my device, or when I receive a call or text, my screen wakes automatically. I think this may be considered a "feature" in android. However, since my phone is nearly always in my pocket, it means that the screen turns on and often receives enough of a false signal in my pocket to disable an alarm or decline/accept a call. It is very inconvenient and would be alleviated if I could specify that I want my device to turn on the screen ONLY when I press the power button.

I know that others have the same problem from searches on xda and elsewhere, but I don't see solutions (except what looks like a registry hack on some specific devices)

Note: I am not looking for a suggestion to get a cover to stop screen interactions while in my pocket, nor do I want to hear about a more elaborate lock screen to keep said interactions from interfering with alarms/calls. The problem is simply that the screen comes on at all with seemingly no way to change the behavior.

Thanks for reading and (hopefully) for helping with this problem.
8th January 2014, 10:22 PM   |  #2  
Junior Member
Thanks Meter: 12
 
25 posts
Join Date:Joined: Sep 2013
I'm not sure it does what you need but you might try IntelliCover: https://play.google.com/store/apps/d....intellicover2

I can't find on its description that function but I read someone solved with that.

good luck
8th January 2014, 11:00 PM   |  #3  
OP Junior Member
Thanks Meter: 0
 
4 posts
Join Date:Joined: Apr 2011
no dice
I installed the recommended app (a neat app, by the way), but it doesn't fix the problem in question. Alarms and communications still wake the screen.

Thanks anyway.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes