Default [Q] Google+ won't install on CyanogenMod 10.0

I was having issues with 4.3 so I flashed the stable CyanogenMod 10.0, and all seems well except for one thing - Google+. When I look for it in the Play Store, it says that my device isn't compatible. I tried sideloading the APK and it installs for a while but then just says "App not installed" with no error code. According to the Play Store web version, it is installed on my Xoom. Anyone run into this? Thanks!