5,606,779 Members 37,486 Now Online
XDA Developers Android and Mobile Development Forum

[Q] run android 4.0 apps on gingerbread

Tip us?
 
yamenma
Old
(Last edited by yamenma; 9th January 2014 at 11:14 AM.)
#1  
Junior Member - OP
Thanks Meter 1
Posts: 3
Join Date: Nov 2013
Default [Q] run android 4.0 apps on gingerbread

hi ! Members
pleas is there is any way to run android 4.0 apps on gingerbread and thanks
 
krishneelg3
Old
(Last edited by krishneelg3; 9th January 2014 at 11:17 AM.)
#2  
krishneelg3's Avatar
Senior Member
Thanks Meter 1114
Posts: 1,499
Join Date: Jan 2012
Location: Auckland City

 
DONATE TO ME
Running Android 4.0 on Gingerbread doesn't particularly make any sense.
What you really mean is, is there any way to run Android 4.0 on your phone? Assuming it's a yes, yes it is possible. It all comes down to what phone you have and if your phone has aftermarket firmware or official updates of the newer os.

If you want the feel of Android 4.0 then j suggest you download a launcher called "Holo Launcher" from the Play Store™.

If that's not what you want, and you want the full package, whole android update of 4.0 then yeah as said. It comes down to your device if it had enough support from members here or the manufacturer itself.

Sent from my Nexus 5 using Tapatalk
The Following User Says Thank You to krishneelg3 For This Useful Post: [ Click to Expand ]
 
yamenma
Old
#3  
Junior Member - OP
Thanks Meter 1
Posts: 3
Join Date: Nov 2013
Quote:
Originally Posted by krishneelg3 View Post
Running Android 4.0 on Gingerbread doesn't particularly make any sense.
What you really mean is, is there any way to run Android 4.0 on your phone? Assuming it's a yes, yes it is possible. It all comes down to what phone you have and if your phone has aftermarket firmware or official updates of the newer os.

If not then the answer is no.

Sent from my Nexus 5 using Tapatalk
i forget to write apps i mean is there is any way to run app which require android 4 to run on gingerbread
 
krishneelg3
Old
#4  
krishneelg3's Avatar
Senior Member
Thanks Meter 1114
Posts: 1,499
Join Date: Jan 2012
Location: Auckland City

 
DONATE TO ME
If that is the case then no, android 4.0 uses new API, and therefore it will not work on gingerbread. If you attempt to install an Android 4.0 app it will come up with and error "problem parsing package".

So once again, nope, you cannot install android 4.0 ( ICS ) Apps on gingerbread.

Sent from my Nexus 5 using Tapatalk
The Following User Says Thank You to krishneelg3 For This Useful Post: [ Click to Expand ]
 
yamenma
Old
#5  
Junior Member - OP
Thanks Meter 1
Posts: 3
Join Date: Nov 2013
my phone is samsung gt-5360 but i can't find real ics with no bugs thanks for you so much krishneelg3
The Following User Says Thank You to yamenma For This Useful Post: [ Click to Expand ]
 
krishneelg3
Old
(Last edited by krishneelg3; 9th January 2014 at 11:36 AM.)
#6  
krishneelg3's Avatar
Senior Member
Thanks Meter 1114
Posts: 1,499
Join Date: Jan 2012
Location: Auckland City

 
DONATE TO ME
There are Applications on the Play Store which is from new android platforms, but will work on older platforms. Search for ICS messaging, camera, gallery. From there you'll find more. And no worries.

Also keep track about the info given fro aftermarket Roms, as developers try to fix everything and soon enough most of the bugs are gone and the ROM can be used a a daily driver.

Sent from my Nexus 5 using Tapatalk
 
Trozzul
Old
#7  
Trozzul's Avatar
Senior Member
Thanks Meter 144
Posts: 1,214
Join Date: Jun 2012
Location: Seattle

 
DONATE TO ME
there are lots of ics+ roms for your device, they all cant be completely buggy, you even have kitkat which is awesome for this small phone.
"A man chooses, a slave obeys." - Andrew Ryan


Samsung Galaxy S2
Rom: Cyanogenmod 10.2 (4.3.1)

Rom: Cyanogemod 10.1.3 (4.2.2)
Asus Nexus 7
Rom: Stock (4.4.2) Broken Digitizer, any recommendations on amazon?
Chromecast
Rom: Stock

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes