Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

SGH-I337M Network Problem

OP Bikster25

5th January 2014, 07:29 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
4 posts
Join Date:Joined: May 2013
My cousin recently got a Galaxy S4 (SGH-I337M) and he got it unlocked from the dealer. A few days ago he took out the SIM ( The phone is telus & the SIM is rogers) & re-inserted it. After that, he couldn't call or text, but the signal strength in the top right was full. In the notification bar, there is a triangle with an exclamation mark & it says no service. In the mobile network settings, if we press register automatically, the exclamation mark goes away but it says unable to connect, try again later. Any help would be appreciated, thanks.
Attached Thumbnails
Click image for larger version

Name:	uploadfromtaptalk1388902858189.jpg
Views:	1859
Size:	29.9 KB
ID:	2495155  
9th January 2014, 10:03 PM   |  #2  
saj222's Avatar
Senior Member
Flag Greater Vancouver Area, British Columbia
Thanks Meter: 135
 
644 posts
Join Date:Joined: Apr 2010
More
At first glance it seems that the phone is still locked to Telus.

Have you tried a Telus SIM? A Telus store would likely let you try one to see or better yet the dealer your cuz got the phone from.

The reason for full signal is that by law (at least in Canada) every phone must be able to call 911 without needing a SIM card inserted.

Sent from my SGH-I337M using Tapatalk
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes