Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,781,214 Members 43,696 Now Online
XDA Developers Android and Mobile Development Forum

[Q] After enabling some xposed modules, my LG G2 (AT&T) is stuck in a error loop.

Tip us?
 
Scaru2
Old
(Last edited by Scaru2; 4th January 2014 at 06:41 PM.) Reason: Update with solution.
#1  
Junior Member - OP
Thanks Meter 0
Posts: 1
Join Date: Sep 2013
Default [Q] After enabling some xposed modules, my LG G2 (AT&T) is stuck in a error loop.

Whenever I boot it up it says "Unfortunately, System UI has stopped.". It does allow me to hit ok, however when I hit ok I have about 1 second before it pops up again. Due to the passcode lock on my phone I am unable to get past the lockscreen as it wipes the input box everytime the popup box pops up. Despite the System UI apparently failing everything does seem to be functional behind the pop up. In the 1 second periods between pop ups I am able to interact with it. The status bar and the buttons on the bottom are not visible, however the rest of the lockscreen (including widgets) is.


The phone is rooted, however I had not gotten around to installing a custom bootloader yet. Debugging is enabled, however the device is listed as "offline" according to "adb devices". Due to this I am unable to install TWRP so as to flash the zip to disable xposed.

All of the above is still true in safe mode, the exact same thing happens.

Does anyone know how to fix this? I would prefer to keep the data on it, however if nothing else a factory reset would be fine.

Update: Solution was to do this. The offending xposed module was xhalofloatingwindow. I have managed to reproduce the error multiple times, so it would appear that xhalofloatingwindow is incompatible with the LG G2 (AT&T) on 4.2.2.
 
ShadowEO
Old
#2  
Senior Member
Thanks Meter 25
Posts: 162
Join Date: Mar 2012
Location: Columbus, Ohio
It is only the latest version that is incompatible. Uninstall Beta 2.16 and install 2.14 then it will work. Came across your post as I was searching in tapatalk for the official thread to report this in. Hope it helps.

Sent from my VS980 4G using xda app-developers app
LG Optimus Select (This phone is no longer in use.)
Asus Nexus 7 FLO (Firmware: PA 3.99-RC2/4.4 using MultiBoot, 4.3 Kernel: ElementalX/4.4 Kernel: AOSP 4.4, Recovery: TWRP)
LG G2 (Carrier: Verizon, Firmware: VS98011A)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes