Default cpu frequency won't lock

OK so I'm running ose ROM 4.4.2 with there kernel and when I go into performance and set the max frequency to the max or any other not even overclocking I set it to 2265 then leave settings and a minute later go back into performance it goes back to being under clocked I can't seem to get the max frequency to stick any thoughts or ideas on getting it to stick