Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,808,657 Members 43,405 Now Online
XDA Developers Android and Mobile Development Forum

Can you downgrade bootloader?

Tip us?
 
xXFl4sh
Old
#1  
xXFl4sh's Avatar
Senior Member - OP
Thanks Meter 21
Posts: 196
Join Date: Nov 2012
Question Can you downgrade bootloader?

I am thinking to flash a 4.4 ROM on my S3 I747M. The only thing I am worried about the bootloader. If I flash the latest boot loader can I downgrade it?

Here a scenario

I am on 4.4 kitkat,with the latest bootloader,and I decide to go back to 4.2.2 with the latest bootloader. Is it possible to do that?
Samsung Galaxy SIII - Liquid Smooth 3.1
Samsung Galaxy Captivate - CM 9
HTC Nexus One - CM 7
HTC Legend - CM 9 Screen does not work
 
poppo101
Old
(Last edited by poppo101; 11th January 2014 at 12:58 AM.) Reason: fixed link
#2  
poppo101's Avatar
Senior Member
Thanks Meter 45
Posts: 100
Join Date: Apr 2012
Location: Mifflinburg, PA
Quote:
Originally Posted by xXFl4sh View Post
I am thinking to flash a 4.4 ROM on my S3 I747M. The only thing I am worried about the bootloader. If I flash the latest boot loader can I downgrade it?

Here a scenario

I am on 4.4 kitkat,with the latest bootloader,and I decide to go back to 4.2.2 with the latest bootloader. Is it possible to do that?
What carrier do you use? If AT&T is it the MJB bootloader.

You can check what bootloader you having using this - https://play.google.com/store/apps/d...s.root_checker

If you are on AT&T with the MJB bootloader you CANNOT downgrade the bootloader. It will brick the phone. My guess is that you could possible run a 4.2.2 ROM with the MJB bootloader. I have run 4.3 and 4.4 on the MG2 bootloader with no problem but haven't tried to run a 4.2.2 on the MJB bootloader. As long as the 4.2.2 ROM doesn't flash a bootloader, I would try it. But that's me. Just back sure to have a current backup. If there are any doubts about the 4.2.2 ROM flashing a bootloader, don't do it if on MJB.
Hit the thanks button if anything I said helped you. -

My Devices -

Samsung ATIV S Neo AT&T I187 - Windows Phone 8.1 Dev. Preview - StraightTalk - Current daily driver

Samsung Galaxy S3 AT&T I747 Blue - KitKat 4.4.2 AT&T OTA - StraightTalk - my play with phone
ASUS Transformer Prime TF201 - running rooted stock 4.1.1
Samsung Captivate SGH-I897 - Retired
Samsung Galaxy S3 AT&T I747 Garnet Red - Was my play phone on MJB bootloader and modem - Sold
 
Andy_nu
Old
#3  
Senior Member
Thanks Meter 250
Posts: 691
Join Date: Feb 2012
Location: Oklahoma
Quote:
Originally Posted by xXFl4sh View Post
I am thinking to flash a 4.4 ROM on my S3 I747M. The only thing I am worried about the bootloader. If I flash the latest boot loader can I downgrade it?

Here a scenario

I am on 4.4 kitkat,with the latest bootloader,and I decide to go back to 4.2.2 with the latest bootloader. Is it possible to do that?
most 4.3 aosp roms can run on the mjb bootloader but you have to modify the updater script to include it. but what the post says above if you try to downgrade the bootloader from mj2 ATT then it will brick the device
 
xXFl4sh
Old
#4  
xXFl4sh's Avatar
Senior Member - OP
Thanks Meter 21
Posts: 196
Join Date: Nov 2012
I have the MVLDLK4 bootloader. The only thing I am worried about is that there might be a few errors while using the ROM. I have tried about 3-4 4.2.2 ROMS but there is always 1 or 2 errors eg. Wifi does not work. Since there is only a few roms on 4.4+, i am worried I wont get a stable rom with minor error.

Cause If I update and the rom has errors, I have no backup rom.
Samsung Galaxy SIII - Liquid Smooth 3.1
Samsung Galaxy Captivate - CM 9
HTC Nexus One - CM 7
HTC Legend - CM 9 Screen does not work
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes