Remove All Ads from XDA

Galaxy Mega SIM Problem

132 posts
Thanks Meter: 10
By d4ndr0id, Senior Member on 11th January 2014, 01:55 AM
Post Reply Subscribe to Thread Email Thread
I have a sgh-i527m (Bell) which got unlocked. I tried a few custom roms but went back to this stock rom since I wanted full functionability.

Periodically, I would get the "no sim card" error. A simple reboot or re-insertion of the sim card usually fixed this issue but earlier today, It just clunked randomly and no matter what I tried, I could not get my sim to work (Fido). I even went to Fido and got a new SIM, since my sim was so old it wasn't even the LTE sim. And still no luck.

I even tried using the scotch tape Nexus fix, still nothing.

I tried re-flashing stock rom, no luck. Going to try a nandroid backup.

Also, my friend's SIM works fine, which is Rogers but my Fido sim won't work yet my Sim works fine in his phone (unlocked i9500). Ironic, because Fido uses the Rogers makes no sense.

Somebody shed some light please?
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes