FORUMS

[Q] Screen replacement - volume flex cable. PLEASE HELP!!!!

65 posts
Thanks Meter: 20
 
By robotzki, Member on 11th January 2014, 02:45 PM
Post Reply Subscribe to Thread Email Thread
Hi,

I just attempted to repalce the screen of my E975. I bought a complete replacement assembly with housing, to make things easier for myself.

However, on the original phone there is a little metal plate where the volume flex cable connects to the motherboard. On the repalcement part, there is no such thing(see pics). I took the volume flex cable and moved it to the new screen assembly and put a piece of doublesided mobile tape on the replacement part, to make it hold and elevate the connector to the same hight as with the metal plate. But now my volume buttons arent working anymore?

Has anybody had some similar problems or could someone help me out how to get my volume buttons to work with this new screen???

I looked everywhere, and all the complete screen assemblies you can buy for the e975, look just like the one i got. So there are none that have that metal plate?
Attached Thumbnails
Click image for larger version

Name:	CAM00036.jpg
Views:	331
Size:	254.3 KB
ID:	2508766   Click image for larger version

Name:	CAM00037.jpg
Views:	369
Size:	247.6 KB
ID:	2508767  
 
 
18th June 2014, 05:49 PM |#2  
Junior Member
Thanks Meter: 0
 
More
I have the same problem! I thought I broke the flex, so I bought a replacement, but it doesn't work either. żDid you resolve it in anyway?
19th June 2014, 11:26 AM |#3  
Junior Member
Thanks Meter: 0
 
More
Hi ! I broke the lcd on november haha, I ordered a new assembly lcd. Please ask me your problem, I dont understand that hehe. I think I could help you ! Haha

PD: Works volumen buttoms !

Please give a better pictures
28th May 2015, 05:38 AM |#4  
Junior Member
Thanks Meter: 2
 
More
Quote:
Originally Posted by robotzki

Hi,

I just attempted to repalce the screen of my E975. I bought a complete replacement assembly with housing, to make things easier for myself.

However, on the original phone there is a little metal plate where the volume flex cable connects to the motherboard. On the repalcement part, there is no such thing(see pics). I took the volume flex cable and moved it to the new screen assembly and put a piece of doublesided mobile tape on the replacement part, to make it hold and elevate the connector to the same hight as with the metal plate. But now my volume buttons arent working anymore?

Has anybody had some similar problems or could someone help me out how to get my volume buttons to work with this new screen???

I looked everywhere, and all the complete screen assemblies you can buy for the e975, look just like the one i got. So there are none that have that metal plate?

Hi. I've got the same problem as you. How did you manage to solve it ?
28th May 2015, 07:42 AM |#5  
OP Member
Thanks Meter: 20
 
More
Quote:
Originally Posted by hardcorekb

Hi. I've got the same problem as you. How did you manage to solve it ?

The little metal plate is supposed to sit on the flex volume cable. Turned out i had separated it from the volume flex cable when disassembling the phone.... I bought a cheap replacement volume cable and that did the trick

Sent from my LG-D802 using XDA Free mobile app
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes