Google Glass-like Clip-On For Regular Glasses Developed by Sony

For the price of $2,000, a pair of glasses that can run apps, take pictures, … more

Micromax Takes OnePlus to Court! Android Wear Receives Lollipop – XDA TV

Android 5.0 Lollipop is available officially for the Moto 360! … more

Google Invites Selected Devs to Buy Project Tango Development Kit

Just about a month ago, the curious Project Tango development kit was … more

YU Yureka: Indian Handset with CyanogenMod

Thesoap opera involving Cyanogen Inc., OnePlus, and Micromax is one of the most talked about … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

(Q) file transfer using usb

OP slaughterer0206

8th January 2014, 05:58 AM   |  #1  
OP Member
Flag KL
Thanks Meter: 3
 
37 posts
Join Date:Joined: Sep 2011
Im new nexus 7 user, just OTA update to 4.4.2 and rooted using wugfresh..

But afterward when i connect to computer, my nexus didnt detected n i cannot assess my sdcard for file transfer.. Anyone can help?



Sent from my GT-I9070 using xda app-developers app
8th January 2014, 06:17 AM   |  #2  
Junior Member
Thanks Meter: 7
 
26 posts
Join Date:Joined: Jan 2013
Quote:
Originally Posted by slaughterer0206

Im new nexus 7 user, just OTA update to 4.4.2 and rooted using wugfresh..

But afterward when i connect to computer, my nexus didnt detected n i cannot assess my sdcard for file transfer.. Anyone can help?

Its a good chance that its a cable problem. Also got in Settings>Storage>[Menu]>Make sure 'MTP' is selected. You can try PTP as well I guess.

If you need to transfer file for emergency purposes use 'Airdroid' for the moment. I think you can use 'ES file explorer' but that would be a little more complicated.
8th January 2014, 06:52 AM   |  #3  
OP Member
Flag KL
Thanks Meter: 3
 
37 posts
Join Date:Joined: Sep 2011
cable work fine... i think some setting im missing or driver in my computer...
8th January 2014, 06:58 AM   |  #4  
Junior Member
Thanks Meter: 7
 
26 posts
Join Date:Joined: Jan 2013
Quote:
Originally Posted by slaughterer0206

cable work fine... i think some setting im missing or driver in my computer...

Download the WugFresh Nexus Toolkit. It has a setup for drivers, maybe that would help. You can also try adb push/pull commands to transfer files via usb.
The Following User Says Thank You to DeepPurple15X For This Useful Post: [ View ]
8th January 2014, 01:33 PM   |  #5  
Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Nov 2013
Go to : settings >> Storage >> USB computer connection , then check the option you want ( MTP or PTP )
in some roms i was not able to connect my device till i uncheck USB debugging form Developer options menu

[ my english is not well ]
9th January 2014, 11:33 AM   |  #6  
OP Member
Flag KL
Thanks Meter: 3
 
37 posts
Join Date:Joined: Sep 2011
Quote:
Originally Posted by Archinux

Go to : settings >> Storage >> USB computer connection , then check the option you want ( MTP or PTP )
in some roms i was not able to connect my device till i uncheck USB debugging form Developer options menu

[ my english is not well ]

i done it... before i root, its work fine.... i able to transfer my file through usb,,,
just after rooting it doesn't appear in my computer
10th January 2014, 02:52 PM   |  #7  
OP Member
Flag KL
Thanks Meter: 3
 
37 posts
Join Date:Joined: Sep 2011
resolved my problem after founded this post
http://forum.xda-developers.com/show...&postcount=338

uninstalled and removed the driver,
then reboot my tab with MTP on, debug mode off...
and it installed the driver for MTP which was missed before...
hehee...
10th January 2014, 09:19 PM   |  #8  
m+a+r+k's Avatar
Member
Thanks Meter: 5
 
51 posts
Join Date:Joined: Aug 2013
More
I gave up getting my XP machine to see the Nexus (Windows 7 laptop is OK).
I now use AirDroid instead, so much quicker and without the hassle of cables, drivers etc.
11th January 2014, 03:35 PM   |  #9  
Junior Member
Flag JG
Thanks Meter: 2
 
13 posts
Join Date:Joined: Oct 2008
More
Quote:
Originally Posted by m+a+r+k

I gave up getting my XP machine to see the Nexus (Windows 7 laptop is OK).
I now use AirDroid instead, so much quicker and without the hassle of cables, drivers etc.

I had connected n7 to winxp at my work computer without installing latest wmp-****. I do remember unpacking wmp-installer then manually installing some libs from it's dirs, but I do not remember if I had to add n7 vid&pid to some inf file. I will try and write some guide
11th January 2014, 07:00 PM   |  #10  
Junior Member
Flag JG
Thanks Meter: 2
 
13 posts
Join Date:Joined: Oct 2008
More
MTP wintout installing WMP11
Hi,

This is just another guide how to install driver and access nexus 7 2013 in windows XP...
  1. Get a WMP install for winXP
  2. Extract it by using command:
    Code:
    wmp11-windowsxp-x86-xx-xx.exe /C /T:[full-path-to-dest-dir]
    eg.
    Code:
    E:\_TEMP\8\>wmp11-windowsxp-x86-xx-xx.exe /C /T:e:\_temp\8\wmp11\
  3. Go into extracted directory, we are interested in files: wmfdist11.exe and umdf.exe
  4. Install them, one is User Mode Driver Framework and other one is "media framework"
  5. Go to
    Code:
    %windir%\inf
    ( eg.:
    Code:
    C:\WINDOWS\inf
    )
  6. Make a copy of file wpdmtphw.inf and open original one in notepad.
  7. Find section [VendorModels.NTx86] (or [VendorModels.NTamd64] if you have winxp 64bit)
  8. At end of section add line:
    Code:
    ; Nexus 7 2013 LTE
    %GenericMTP.DeviceDesc%=MTP, USB\VID_18D1&PID_4EE2&REV_0228&MI_00
  9. Reboot your computer. Unplug also your Nexus, also switch off USB Debugging because of that you will see two MTP devices and you might try install MTP drivers for debug (which fail, or windows will yell with code 10...)
  10. Hook up Nexus and when windows popup about installing drivers, choose that you have driver and the location point to search set to
    Code:
    c:\windows\inf
    , click next, windows might complain that this driver is not intended to use with this device, so give win a slap and wait patiently until windows install driver
Windows might install drivers twice, just remember to point to windows/inf directory or directory with google usb driver http://developer.android.com/sdk/win-usb.html


---------------
After almost a year I noticed I made a hell of mistake , There should be MI_00 (MI stands for Media Interface 0) not MI_01 (MI 01 is for ADB ). And There is no need for 1st line ( USB\VID_18D1&PID_4EE2&MI_00 ).
I am terribly sorry for committing such basic error.

I already fixed those error in this my "guide"...
Last edited by saper_2; 3rd December 2014 at 05:38 PM. Reason: Fixed almost grave mistake. Added location to google drivers.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes