Battery Low [SOLVED]"Sleep Of Death" mode after 10 seconds lights off/ locked screen

hi guys...
I've got my sensation on the second hands condition yesterday...
it's very cheap coz there's somethin error ( not sure it's hw or sw problem )

like the title said, power turned off it self after 10 seconds lights off/ locked screen...
I can't do anything after that except pull the battery out n put it again for turning on...

but if I plug in the USB cable/ charge it with "always wake" screen, it never died as a normal...

if I try to factory reset then remove the SIM card n SD Card or in Air plane mode, it's working fine w/o any problem...
but when I put the SIM card n activate mobile data, the problem just appear...

do anyone had ever this problem? is it sw or hw problem?
I wanted try another ROMs but my motherboard is kinda new/ replaced, i can't unlock the bootloader n install custom recovery...

yes, I knew there's a guide for me to do S-OFF by ganeshp. but always failed on wire-trick ( program can't read the phone coz QHSUSB_DLOAD driver not found ). I'm using Windows xp and 7 to execute...

so, that's my problem, I hope I will get any solution in here soon...

best regards
yayakuya

--edit--update--

Now while i'm S-OFF and 4EXT recovery installed, then i try to flash custom ROM to see if it made any changes...
trying ViperS JB with Sense 4+ and CM11 by Android123456
Seems like the SOD still persist on my Sensation

Got another Tip, i will try to flash with stock RUU
will edit this post, when i was finish with it.... ==> didn't working... still persist...

--edit--update 2--


my guess, there's something happens to the radio, SIM card connector or similarly... coz when on flight mode, SOD doesn't came up...

for temp fix, i'm using Cpu Wake app from store...
problem was gone, but i think new problem shown up...
battery drain faster... setup the cpu for 197~972MHz
cpu can't reach the deep sleep, but while screen off, cpu idle
running on lowest frequency ( 197MHz ) on CM11

--edit--Solved--

Finally it's over...
but only by an accident...
this is what i've done:
1. Flash ViperS 5.0 ROM with Sense 5 > No, SoD still remains...
2. On that ROM installed, i perform some experiments by flash another Kernels on here...
3. Wipe boot with Powerful Kernel Reset > flash Sultan-kernel-r18-Sense-Aroma.zip > reboot > Stucked at boot animation
4. Wipe boot with Powerful Kernel Reset > flash TYD_Kernel_test4.1.9.zip > reboot > Stucked at boot splash
5. Wipe boot with Powerful Kernel Reset > Advance Restore backed up boot > reboot > Test it > Wallaa....

I can going into Deep Sleep without SoD for now!!!

Attached Thumbnails
Click image for larger version

Name:	Screenshot_2014-01-19-18-25-52.png
Views:	141
Size:	209.2 KB
ID:	2525698  
 
PM Me for all my works will not Replied!!!
Post your comments nor questions in specified Thread, THANKS

ALL MY WORKS 4 XPERIA E/ Xperia Devices
ALL MY WORKS 4 LG E400

Indonesian Developer
from Indonesia for all over the world