Default [Q] Primou Omega Stuck at inital boot.

I have downloaded and installed Primou Omega ROM. I have followed the instructions in the thread. Every thing went very well untill first boot. Now the phone is stuck at CyanogenMod Logo. I have waited for almost for one hour hoping that it will complete. But noting is happening. I tried twice but same result. Here are the steps that i followed.
  1. Unlocked bootloader.
  2. Rooted device.
  3. Installed ClockworkMod.
  4. Download Primou Omega.
  5. Download Google Apps.
  6. Booted into ClockworkMod.
  7. Done a Data wipe.
  8. Wiped dalvik cache.
  9. Done Format system (From Mounts and storage).
  10. Installed Primou Omega ROM (Install zip from SD card).
  11. Installed Gapps.
  12. Rebooted the system.

Before doing these steps i took a backup of the stock ROM so i was able to restore it.
Now, i'm i missing something. I'm new to flashing new ROM etc... Is there a error log of the installation process so that i can post it in the forum.
Please help.

EDIT: Issue Resolved I had to use a different Kernel (CM 10).And it booted with out any issue. Didn't find any issue till now....