FORUMS

Index Project For XDA Device Subforums

Another ambitious project from the collaborative efforts of Recognized Contributors and Forum … more

The Atlas of XDA

A few weeks ago, we asked you “How Does Your Location Affect Your Life As A Power User?”. In the days that … more

New Snapdragons: Some Context & Contrast

It hasn’t been a good year for Qualcomm so far. Every device featuring the Snapdragon 810 … more

Google To Launch Next Gen Android One On July 14

The first gen of Android One devices to be launched in India in September 2014 were … more

[Q] VILLUMINATI ART Problems

7 posts
Thanks Meter: 1
 
By Zaverns, Junior Member on 12th January 2014, 12:47 AM
Post Reply Subscribe to Thread Email Thread
About a week ago I installed the VILLUMINATI Unofficial version of Cyanogenmod 11, which gave me Android 4.4.1. I've had no problems with it so far until I tried to enable the ART runtime. I enabled it and it started up alright, but after the boot process gapps kept crashing. I tried looking through the thread and didn't see anything (unless I missed it), and tried re-downloading and re-flashing the gapps, but to no avail. I switched back to Dalvik runtime and everything went back to normal. I was hoping someone had a fix for this so I could save a little extra battery and make my phone run a bit faster with ART. Thanks for your time.
 
 
12th January 2014, 02:13 AM |#2  
Junior Member
Thanks Meter: 1
 
More
what gapps are you using?
Quote:
Originally Posted by Zaverns

About a week ago I installed the VILLUMINATI Unofficial version of Cyanogenmod 11, which gave me Android 4.4.1. I've had no problems with it so far until I tried to enable the ART runtime. I enabled it and it started up alright, but after the boot process gapps kept crashing. I tried looking through the thread and didn't see anything (unless I missed it), and tried re-downloading and re-flashing the gapps, but to no avail. I switched back to Dalvik runtime and everything went back to normal. I was hoping someone had a fix for this so I could save a little extra battery and make my phone run a bit faster with ART. Thanks for your time.

The problem must be coming from the gapps you installed ...what gapps are you using? It might not have the google apps that are compatible with ART

Use the PA mini modular gapps...(sorry I can't give you the link since I don't have 10 posts -__- Lol)
I recommend this specific one because the full & google stock gapps has had a history of causing some issues..
Last edited by KingOz; 12th January 2014 at 02:40 AM. Reason: Forgot To Post Link
The Following User Says Thank You to KingOz For This Useful Post: [ View ]
12th January 2014, 02:54 AM |#3  
beezie42's Avatar
Senior Member
Flag Traverse City, MI
Thanks Meter: 50
 
More
Quote:
Originally Posted by Zaverns

About a week ago I installed the VILLUMINATI Unofficial version of Cyanogenmod 11, which gave me Android 4.4.1. I've had no problems with it so far until I tried to enable the ART runtime. I enabled it and it started up alright, but after the boot process gapps kept crashing. I tried looking through the thread and didn't see anything (unless I missed it), and tried re-downloading and re-flashing the gapps, but to no avail. I switched back to Dalvik runtime and everything went back to normal. I was hoping someone had a fix for this so I could save a little extra battery and make my phone run a bit faster with ART. Thanks for your time.

The only way I was able to get ART to run without force closes, was to reboot to recovery as soon as you select the ART runtime. Then wipe both cache and dalvik cache. Then reboot. I had zero force closes this way.

Also remember ART is fairly new so some apps may not work correctly.

Sent from my SPH-D710 using XDA Premium 4 mobile app
The Following User Says Thank You to beezie42 For This Useful Post: [ View ]
12th January 2014, 07:31 AM |#4  
OP Junior Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by KingOz

The problem must be coming from the gapps you installed ...what gapps are you using? It might not have the google apps that are compatible with ART

Use the PA mini modular gapps...(sorry I can't give you the link since I don't have 10 posts -__- Lol)
I recommend this specific one because the full & google stock gapps has had a history of causing some issues..

I am using the gapps that was included in the VILLUMINATI post. The below post fixed my problem though, I appreciate your reply and will follow this method if I encounter any further problems. Thanks!

Quote:
Originally Posted by beezie42

The only way I was able to get ART to run without force closes, was to reboot to recovery as soon as you select the ART runtime. Then wipe both cache and dalvik cache. Then reboot. I had zero force closes this way.

Also remember ART is fairly new so some apps may not work correctly.

Sent from my SPH-D710 using XDA Premium 4 mobile app

This did work for me, thank you! At first after reboot my power button would not turn off the screen, but it started working shortly after. I hope that isn't anything I should look in to.
12th January 2014, 03:05 PM |#5  
beezie42's Avatar
Senior Member
Flag Traverse City, MI
Thanks Meter: 50
 
More
Your welcome. Sometimes ART seems to work better. A few apps I had trouble getting to install. But they worked after a few reboots.
Not sure about the power button, sorry. Could of been just a hic up.

Sent from my SPH-D710 using XDA Premium 4 mobile app
The Following User Says Thank You to beezie42 For This Useful Post: [ View ]
12th January 2014, 04:24 PM |#6  
bilgerryan's Avatar
Recognized Developer
Flag Garrett, IN
Thanks Meter: 34,118
 
Donate to Me
More
I don't know if this will help, but a utile more information never hurt anybody-http://www.infinum.co/the-capsized-e...ime-in-kit-kat

The Following User Says Thank You to bilgerryan For This Useful Post: [ View ]
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes