Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,769,248 Members 39,080 Now Online
XDA Developers Android and Mobile Development Forum

[SOLVED] Local WiFi speed trouble

Tip us?
 
Lightning-
Old
(Last edited by Lightning-; 13th January 2014 at 03:59 PM.)
#1  
Lightning-'s Avatar
Junior Member - OP
Thanks Meter 5
Posts: 11
Join Date: Aug 2012
Arrow [SOLVED] Local WiFi speed trouble

EDIT: SOLVED, if you encounter the same problem, use HTTP or FTP protocol, don't use ES Explorer.

Hi,

I'm experiencing a big trouble with the WiFi of my Z1 C6903. My router is : Freebox V6, WiFi N 2.4GHz maximum. My average speed (at 0 meter of him, for testing) with it, is 2-3.5 Mo/s max with a local transfer (with ES Explorer) like this : Router + Integrated NAS -> Z1, downloads or uploads have the same average speed.

So, for using the Z1 (and other devices..) at the maximum WiFi speed, I've buyed this router : Archer C7 AC1750, WiFi AC 5GHz (with three external 5GHz antenna).
On stock Sony 4.3 rom, i've got (at 0 meter of him) a speed up to 6 Mo/s (4-6 Mo/s is average). On a custom rom (SlimKat V7 for exemple), the speed is even worst (2-3 Mo/s, not stable).

The router cannot be the faulty, because i've tested it with a Macbook Air 2012, connected with WiFi N 5GHz, the speed is 22Mo/s (at 0 meter of the router, of course), and 8-9 Mo/s with 2.4GHz, and i've tested a lot of option on him (WPA2, AES, Channels, etc..).

So, what's the point ? The WiFi of the Z1 is realy crappy or i have a defective Z1 you think ? I'm lost.
Thanks for reading me.
Attached Thumbnails
Click image for larger version

Name:	Screenshot_2014-01-12-16-41-06.jpg
Views:	677
Size:	94.2 KB
ID:	2511317   Click image for larger version

Name:	Screenshot_2014-01-12-15-58-03.png
Views:	709
Size:	135.3 KB
ID:	2511318  
 
x102x96x
Old
#2  
x102x96x's Avatar
Senior Member
Thanks Meter 278
Posts: 1,272
Join Date: May 2012
Location: Linux

 
DONATE TO ME
Quote:
Originally Posted by Lightning- View Post
Hi,

I'm experiencing a big trouble with the WiFi of my Z1 C6903. My router is : Freebox V6, WiFi N 2.4GHz maximum. My average speed (at 0 meter of him, for testing) with it, is 2-3.5 Mo/s max with a local transfer (with ES Explorer) like this : Router + Integrated NAS -> Z1, downloads or uploads have the same average speed.

So, for using the Z1 (and other devices..) at the maximum WiFi speed, I've buyed this router : Archer C7 AC1750, WiFi AC 5GHz (with three external 5GHz antenna).
On stock Sony 4.3 rom, i've got (at 0 meter of him) a speed up to 6 Mo/s (4-6 Mo/s is average). On a custom rom (SlimKat V7 for exemple), the speed is even worst (2-3 Mo/s, not stable).

The router cannot be the faulty, because i've tested it with a Macbook Air 2012, connected with WiFi N 5GHz, the speed is 22Mo/s (at 0 meter of the router, of course), and 8-9 Mo/s with 2.4GHz, and i've tested a lot of option on him (WPA2, AES, Channels, etc..).

So, what's the point ? The WiFi of the Z1 is realy crappy or i have a defective Z1 you think ? I'm lost.
Thanks for reading me.
it s about compatibility of XZ1 with ur router
try to test Z1 with another router
if everything go right u should know ur router (or maybe firmware of ur router) not compatible wiht ur Xperia.
test more and write more about it...
 
Java.Symbian.WP8.iOS4/5/6/7
Android; Fy \GB \ICS \JB \KK \CustomROM
Devices; Nexus \Xperia \Galaxy \LG \htc \Lenovo
./Android-Ubuntu Programming

 
Lightning-
Old
(Last edited by Lightning-; 26th January 2014 at 03:40 PM.)
#3  
Lightning-'s Avatar
Junior Member - OP
Thanks Meter 5
Posts: 11
Join Date: Aug 2012
Default SOLVED

Thanks for the reply.
I have doing some investigation, and i found the problem (and meanwhile I upgraded the firmware of the router, Macbook maximum speed now peak at ~27Mo/s and i change aes to Disable Security in router, using mac filter instead).
When i use HTTP protocol (with Chrome) or FTP (with FTP Client) , i was able to download (and upload) at .. 23 Mo/s !
With ES Explorer, the maximum speed was only up to 6Mo/s (SMB or FTP) ! I don't know why ..

So, i don't think 23Mo/s was the max of WiFi AC, but it's already pretty decent and im now happy !
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes