Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] GS4 4.3 stops responding to ping after a few seconds

OP lordbah

7th January 2014, 04:06 PM   |  #1  
OP Junior Member
Thanks Meter: 1
 
10 posts
Join Date:Joined: Jun 2013
We have a Windows box with a wifi dongle and we're having an issue when a customer with a GS4 running Android 4.3 connects to it. The connection and DHCP negotiation work correctly. Once that happens we begin pinging the phone twice per second*. The phone answers the pings for about 3 seconds, and then never answers a ping again. The phone screen is not turned off. The user hasn't left the mobile app, hasn't killed any tasks or anything like that. Does anyone have information on why the GS4 would stop responding to ping?

I've read that there are issues with this phone/OS *originating* ping - that is NOT the case here. The 'ping' command is never used on the phone. The phone is receiving pings.

Pings are not entirely blocked since it responds correctly for the first few seconds (though not quickly - usually well over 40ms).

This feels - wild guess, could be way off base - more like the GS4 has determined that these pings are some kind of attack and therefore decided to stop responding. Is there anything like that in there? I don't know who would know the internals.

We have not seen the issue with GS3 4.3. We don't currently have any other devices running 4.3, though there is one Galaxy Nexus which could be upgraded.


* Why? Two reasons.
1. The Realtek function which we can call on our computer to determine whether there are any wifi clients connected quite frequently returns false data, and Realtek won't help us. Thus ping is now our method of detecting when the user has walked away.
2. Some older phones (not GS4) are quite sluggish in the ensuing file transfers from our mobile app unless 'prodded' in this manner. We haven't figured out why. It's like they need to be kept awake at a sub-second level.
13th January 2014, 04:37 PM   |  #2  
OP Junior Member
Thanks Meter: 1
 
10 posts
Join Date:Joined: Jun 2013
Some cases were nothing complicated - the phone was deciding that the quality of the wi-fi connection stank so it was switching back to 3g. Turning off Auto Network Switch in the phone's Wi-Fi / Advanced settings fixed that. Other cases continue to show the problem even with that switch disabled.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes