Android 5.1 Possibly Coming February 2015

Google released Android 5.0 just over a month ago, and since then Lollipop has been trying to … more

Double Tap to Wake on the Nexus 6 Without Root

A few weeks ago, we featured an app which allowed the Nexus 6 to regain the double tap to wake … more

Make Your Own Heat Sink for the LG Optimus 4X HD

Its not a rare occurrence that performing a resource heavy task on your Android device (e.g. … more

Learn How to Create an Old School Dialer

XDA is not only a great source for custom ROMs, kernels, and various modifications for numerous … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Nexus 7 2013 Becoming Slow.

OP Strike_Riku

11th January 2014, 11:16 PM   |  #1  
Strike_Riku's Avatar
OP Senior Member
Thanks Meter: 130
 
768 posts
Join Date:Joined: Dec 2012
Hey,
I got my N7, 16GB WiFi, 1 month(s) ago, and it was amazing. I was playing games, like Modern Combat 4, at a super smooth frame rate, I was browsing the web at amazings FPS's, just the general UI was so fluid.
The day I got it, I unlocked, flashed a recovery and rooted. I play the game I mentioned above, MC4, a lot and am quite good at it. I though that it would be a good idea to record what I was doing and show the world! (www.youtube.com/user/StealthGamingAndroid if you want to see)
The game was smooth before, just playing, and was still smooth after. What impressed me was that even while recording, it felt like I still had amazing frames.
About a week or so ago, that stopped. I was getting lag, the game was jittery and making the whole thing unplayable, even when not recording. But it wasn't just the game. The whole UI felt, even though it wasn't terrible, sluggish.
I didn't/haven't changed my setup, regarding ROM, Kernel or Processor Speeds since the day I got it. It is running the version of 4.3 it came with out of the box. (My choosing to keep it on that and not update)
The only things I have done regarding root have been using SCR Pro, the recording software, and using Xposed and Gravitybox.

I do not know what is causing this sudden lag, and how I can fix it. A brief search on Google didn't turn up anything that I could relate to. So I present to you my question.

How do I fix this lag?

I do not mind if it means using root, flashing a new ROM or even a new kernel. (Never flashed a different kernel on all 4 of my devices) Over clocking I also haven't done, but if it means removing the lag, I will consider it.
I am extremely grateful for what ever solutions or suggestions you give me, and will happily look into them.
Thank you for your time reading this, and for helping a confused user out.
Faithfully,
-R
11th January 2014, 11:21 PM   |  #2  
mdamaged's Avatar
Senior Member
Flag South of Heaven
Thanks Meter: 1,069
 
1,671 posts
Join Date:Joined: Oct 2013
More
Boot into recovery, clear you caches, boot normally, see if that fixed it, if not...boot into safe mode and see if the problem persists, if that fixed it, it's one or more of your apps, you'll have to either flash to stock and reinstall one at a time, when it starts lagging again you've found the app, or remove one at a time and see when it stops, if the problem still occurs in safe mode, backup and flash back to stock and see if it persist, if it does, maybe it's hardware.
Last edited by mdamaged; 11th January 2014 at 11:26 PM.
The Following User Says Thank You to mdamaged For This Useful Post: [ View ]
12th January 2014, 07:39 PM   |  #3  
Strike_Riku's Avatar
OP Senior Member
Thanks Meter: 130
 
768 posts
Join Date:Joined: Dec 2012
Quote:
Originally Posted by mdamaged

Boot into recovery, clear you caches, boot normally, see if that fixed it, if not...boot into safe mode and see if the problem persists, if that fixed it, it's one or more of your apps, you'll have to either flash to stock and reinstall one at a time, when it starts lagging again you've found the app, or remove one at a time and see when it stops, if the problem still occurs in safe mode, backup and flash back to stock and see if it persist, if it does, maybe it's hardware.

That has fixed some of it, but it still feels choppy. (The wiping of the caches, I mean)

#Nexus
13th January 2014, 05:38 AM   |  #4  
Junior Member
Thanks Meter: 0
 
5 posts
Join Date:Joined: Dec 2013
Quote:
Originally Posted by Strike_Riku

That has fixed some of it, but it still feels choppy. (The wiping of the caches, I mean)

#Nexus

I use an app called Clean Maste. You can get it in the Play Store. It's basically like CC Cleaner on the computer (if you don't have it, get it!). Just clear all the stuff in the junk option EXCEPT obsolete APKs. If you know what you're doing, cleaning in Junk Advanced can help too.
Also, be sure to delete all the apps you don't need, and clear your multitasking often.

For a big performance boost. you can overclock your tablet. First, tell us if the other things work above. If not, PM me and I'll be glad to teach you to overclock
13th January 2014, 10:36 AM   |  #5  
PhilipTD's Avatar
Senior Member
Thanks Meter: 387
 
1,748 posts
Join Date:Joined: Dec 2010
Quote:
Originally Posted by Strike_Riku

... How do I fix this lag?...

Did you try uninstalling Xposed?
13th January 2014, 02:39 PM   |  #6  
Senior Member
Thanks Meter: 82
 
167 posts
Join Date:Joined: Feb 2012
When my tablet lags a little, I usually turn it completely off for a couple minutes. This helps me quite a bit.

This may sound dumb or crazy but you got to remember that it's a computer and turning it off once or twice a week will clear the cobwebs.
13th January 2014, 05:25 PM   |  #7  
PhilipTD's Avatar
Senior Member
Thanks Meter: 387
 
1,748 posts
Join Date:Joined: Dec 2010
Quote:
Originally Posted by IndianaBond

When my tablet lags a little, I usually turn it completely off for a couple minutes. This helps me quite a bit.

This may sound dumb or crazy but you got to remember that it's a computer and turning it off once or twice a week will clear the cobwebs.

Totally agree.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes